Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 198771 - Standard shortcut for Test Results window action
Standard shortcut for Test Results window action
Status: VERIFIED FIXED
Product: utilities
Classification: Unclassified
Component: Test Runner
7.0
All All
: P3 (vote)
: 7.4
Assigned To: Petr Somol
issues@utilities
: A11Y
Depends on:
Blocks: 211167
  Show dependency treegraph
 
Reported: 2011-05-20 17:26 UTC by Jesse Glick
Modified: 2013-07-22 13:03 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-05-20 17:26:57 UTC
The Test Results window is (I suppose) quite widely used, yet there is no keyboard shortcut for opening it (besides the mnemonic 'Alt-W O T').

I first thought of Alt-Shift-T. This is currently taken by ThreadsHistoryAction in debugger.jpda.ui. While I have no idea what that action does (nor can I find where or how to invoke it), it seems to be used from several other classes in the module whose control flow I cannot follow - lots of low-level manipulation of keyboard commands. Written by dprusa.

Alt-Shift-R is another plausible shortcut. This is currently taken by RunFrameworkCommandAction in php.project, which as far as I can tell has no other UI presentation so I am not sure how anyone is supposed to know it even exists, unless tmysik blogged about it or something.

The 7.0 shortcuts.pdf mentions neither of these. It seems to me that opening Test Results is a more basic action that is more deserving of a standard shortcut.
Comment 1 Antonin Nebuzelsky 2011-05-27 11:42:15 UTC
Martine, please comment about the shortcut Alt-Shift-T and if you could make it available for Test Results.
Comment 2 Martin Entlicher 2011-05-30 11:37:31 UTC
The ThreadsHistoryAction have the shortcut declared in the standard way in the module layer XML. It reuses the shortcut for later use and this is why it manipulates with the key events.

I did not find a mail from anyone about Alt-Shift-T shortcut, but I believe that Dan defined this shortcut after negotiations with Roman, who was our UI representative.
I think that HIE should define shortcuts for individual actions, so I do not want to do random changes without the knowledge of what shortcuts are used in other areas.

I agree that Test Results window might be more important. We may use e.g. CTRL-ALT-SHIFT-T for ThreadsHistoryAction, which seems to be available. But I think that this should be confirmed by HIE.
Comment 3 Jesse Glick 2011-09-06 13:43:15 UTC
A-S-R now taken by Toggle Rectangular Selection.
Comment 4 Jesse Glick 2011-10-19 00:24:23 UTC
As of 7d7b4f099ddf, Ctrl-Shift-R is free.
Comment 5 Jesse Glick 2012-02-22 19:35:11 UTC
Petr is now handling accelerators I guess. Please consider C-S-R for opening the Test Results window.
Comment 6 Petr Somol 2012-03-02 15:41:20 UTC
AFAIK in 7.1 as well as in the current builds 
Ctrl-Shift-R represents Toggle Rectangular Selection.
Ctrl-Shift-T represents Go To Test
Alt-Shift-T represents Threads History
Alt-Shift-R seems free

Tried it on the daily build with all modules from update center installed.

I plan to but have not completed yet the full review of all shortcuts. Unfortunately I will not be able to manage that before 7.2 code freeze.. sorry.
Comment 7 Theofanis Oikonomou 2013-01-28 14:15:40 UTC
Petr, can you now confirm that Alt-Shift-R can be used as the default shortcut? Thaks
Comment 8 Theofanis Oikonomou 2013-02-05 16:23:18 UTC
Honza could you comment if Alt-Shift-R can be used as the default shortcut?
Thank you
Comment 9 Jan Peska 2013-02-06 08:34:54 UTC
Well as Petr said Alt-Shift-R seems to be available. Petr, do you think a further evaluation is needed or/and do you want to finish the review of shortcuts first? If not, I think you can implement it Fanis.
Comment 10 Petr Somol 2013-02-20 12:35:21 UTC
(In reply to comment #9)
> Well as Petr said Alt-Shift-R seems to be available. Petr, do you think a
> further evaluation is needed or/and do you want to finish the review of
> shortcuts first? If not, I think you can implement it Fanis.

The overall review is not finished yet but waiting for that would be counter-productive. I think we should give a go to Fanis.
Comment 11 Theofanis Oikonomou 2013-02-20 12:50:36 UTC
(In reply to comment #10)
> The overall review is not finished yet but waiting for that would be
> counter-productive. I think we should give a go to Fanis.

great, thanks!
Comment 12 Theofanis Oikonomou 2013-02-20 13:19:49 UTC
Changeset: 99b06db97fd9
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-02-20 14:17
Message:   
Issue #198771 - Standard shortcut for Test Results window action
Comment 13 Quality Engineering 2013-02-23 04:12:25 UTC
Integrated into 'main-golden', will be available in build *201302222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/99b06db97fd9
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #198771 - Standard shortcut for Test Results window action
Comment 14 Jiri Kovalsky 2013-07-22 13:03:17 UTC
Product Version: NetBeans IDE Dev (Build 201307212300)
Updates: Updates available
Java: 1.7.0_40-ea; Java HotSpot(TM) 64-Bit Server VM 24.0-b52
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-ea-b33
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo