Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 198417 - Show full/Resize connection error message on New Connection Wizard
Show full/Resize connection error message on New Connection Wizard
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.0
PC Windows 7 x64
: P3 with 1 vote (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
patch-awailable
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-07 22:43 UTC by azizur
Modified: 2013-04-10 15:20 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
001.png - the window at normal size (124.72 KB, image/png)
2011-05-07 22:43 UTC, azizur
Details
002.png - when er-sized horizontally (152.88 KB, image/png)
2011-05-07 22:44 UTC, azizur
Details
003.png - how it should be.... (141.76 KB, image/png)
2011-05-07 22:44 UTC, azizur
Details
proposed patch v1 (4.80 KB, patch)
2012-08-25 19:09 UTC, matthias42
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description azizur 2011-05-07 22:43:54 UTC
Created attachment 108167 [details]
001.png - the window at normal size

The connection error message on New Connection Wizard for mySQL (Connector/J driver) Dialogue Window is not readable.

How to re-produce?

1) Open Services Panel (Ctrl+5)
2) expand Databases list -> Drivers
3) right-click MySQL (Connector/J driver) and select "Connect Using..." and you'll be presented with New Connection Wizard for mySQL (Connector/J driver) Dialogue Window
4) fill in the details with some database server details that does not work
5) Press "Test COnnection" button and wait
6) You should get error message saying cannot establish connection ....

Now the error message is so long it's not possible to read the entire message. You can resize the  Dialogue Window vertically but still not readable. If you resize horizontally and its readable on large (17inch) monitor.


See attached images for details.
Comment 1 azizur 2011-05-07 22:44:25 UTC
Created attachment 108168 [details]
002.png - when er-sized horizontally
Comment 2 azizur 2011-05-07 22:44:43 UTC
Created attachment 108169 [details]
003.png - how it should be....
Comment 3 azizur 2011-06-09 15:07:43 UTC
It's been a month now. Would anyone give an update on this?
Comment 4 locked 2011-08-05 07:17:55 UTC
Confirmed on
Product Version: NetBeans IDE 7.0.1 (Build 201107282000)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Windows 7 version 6.1 running on amd64; Cp1252; de_DE (nb)

It also applies for Derby.
I assume it's independent from the DB driver but an issue of the diplaying dialog.

Proposed solution: replace the JLabel (I assume!) with a scrollable and possible resizable text field displaying the error.
Comment 5 Jiri Rechtacek 2011-08-05 08:03:48 UTC
I'll look on it.
Comment 6 matthias42 2012-08-25 18:51:28 UTC
The mentioned problem roots in the wizard descriptor. A message of a wizard could always be longer than one line, so there needs to be a way to display the complete message.

I'll attach a patch that adds a button with an ellipsis symbol to the errorpanel. When that button is clicked a notification with the whole message is generated.
Comment 7 matthias42 2012-08-25 19:09:48 UTC
Created attachment 123568 [details]
proposed patch v1
Comment 8 Stanislav Aubrecht 2012-09-12 08:37:11 UTC
The full error/warning is available in a tooltip, isn't that enough?
Comment 9 locked 2012-09-12 18:07:54 UTC
I'm afraid but I don't think that the tooltip is enough.
If I see such a dialog, it's pure luck if I try the tooltip approach.
Ideally the errormessage can even be copied to the clipboard (Just in case when I want to copy the message and send it to s.o. else).
Comment 10 Petr Somol 2012-09-18 08:11:49 UTC
From UEX point of view having a lengthy message cropped in dialog and having it accessible only through tooltip is not satisfactory. Even the solution with a button that would open an error panel is not optimal.

Do I understand it right that the message is not generated inside NB and that that is the reason why there is problem to break it into several lines ? But even if NB infrastructure generally does not do this automatically, I hope it should be possible to intercept the message string in this particular case and to insert linebreaks into it so that it gets displayed in full in ordinarily sized dialog..
Comment 11 Stanislav Aubrecht 2013-02-27 15:45:17 UTC
It is not a problem to wrap error messages. The problem is that it would mean that either scrollbars would show in the wizard window or the whole wizard window would need resize with every message change. I don't think that either solution is acceptable. 
But the connection dialog window can implement its own error messaging...
Comment 12 Stanislav Aubrecht 2013-04-10 15:20:45 UTC
The text in error/info message is selectable with mouse so Ctrl+C copies the text to system clipboard.
I've also added popup menu with 'Copy to Clipboard' item.

core-main a33d1685be85


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo