Bug 198132 - Improve Mac Native installer for NetBeans
Improve Mac Native installer for NetBeans
Status: RESOLVED DUPLICATE of bug 217940
Product: installer
Classification: Unclassified
Component: Mac Native
7.0.1
Macintosh Mac OS X
: P2 with 1 vote (vote)
: 7.3
Assigned To: Jiri Rechtacek
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 13:22 UTC by Yulia Novozhilova
Modified: 2012-10-07 13:08 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yulia Novozhilova 2011-04-27 13:22:44 UTC
There are two approaches for Mac Native installation of NetBeans.

The first one is used now. It is based on GUI installer created by PackageMaker tool and running by Installer tool. This approach should be elaborated since Snow Leopard introduces some changes in Installer and PackageMaker tools that need to be taken into account. Questions with the ownership and installation location should be resolved in a proper way instead of "hucking" the installation in postinstall scripts(#197678, #151681, #177872).


The second one is to supply the user with *.app file only, so that he could install it in any place he wants. This approach is not implemented since there is a difficulty with configuration and unpack200, but it would be nice to dig into it a bit more.
Comment 1 Jiri Rechtacek 2012-10-07 12:58:44 UTC
Assigned to new owner.
Comment 2 Jiri Rechtacek 2012-10-07 13:08:44 UTC

*** This bug has been marked as a duplicate of bug 217940 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo