Bug 197734 - Modify J2SEProject build scripts to use TestNG if available
Modify J2SEProject build scripts to use TestNG if available
Status: RESOLVED DUPLICATE of bug 208873
Product: java
Classification: Unclassified
Component: Project
7.0
All All
: P3 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@java
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 10:14 UTC by Jaroslav Tulach
Modified: 2012-03-01 12:06 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments
Bundled Hg repository with sample project (1.78 MB, application/octet-stream)
2011-04-14 10:14 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2011-04-14 10:14:28 UTC
Created attachment 107748 [details]
Bundled Hg repository with sample project

I am experimenting with TestNG and I'd like to use the TestNG's Ant task to run the tests (both JUnit as well as TestNG) if testng.jar is on classpath.

I guess it can be done with small conditional check in build-impl.xml. I am going to attach my sample project (use "hg unbundle project.hg" to get it). The following changeset contains the actual change in the build-impl.xml.

changeset:   2:0e853fceeda0
user:        Jaroslav Tulach <jtulach@netbeans.org>
date:        Thu Apr 14 12:07:34 2011 +0200
summary:     Run with TestNG Ant task if it is available

Not everything is working yet: I cannot execute both JUnit and TestNG tests at once. The Test Results window does not show anything yet.
Comment 1 Jaroslav Tulach 2012-02-24 10:58:39 UTC
After the recent work by Lukáš Jungmann the dual mode execution should not be a problem anymore: http://wiki.apidesign.org/wiki/TestNG

Also other Lukáš's work could solve the issue with results window.
Comment 2 Lukas Jungmann 2012-03-01 11:32:20 UTC
isn't this a duplicate of issue #208873? Possible patch is already attached there, so I think this can be resolved/closed.
Comment 3 Tomas Zezula 2012-03-01 12:06:53 UTC

*** This bug has been marked as a duplicate of bug 208873 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo