Bug 197729 - Add support for Symfony2
Add support for Symfony2
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Symfony
7.1
All All
: P2 with 179 votes (vote)
: 7.2
Assigned To: Tomas Mysik
issues@php
:
: 199825 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 06:46 UTC by thaberkern
Modified: 2012-06-19 08:34 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Vote (45.11 KB, image/jpeg)
2011-04-19 13:00 UTC, umpirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thaberkern 2011-04-14 06:46:59 UTC
* Twig-Support
* CLI-Support
Comment 1 bkuberek 2011-04-18 04:08:15 UTC
+1
Comment 2 umpirsky 2011-04-18 11:18:34 UTC
+1
Comment 3 FractalizeR 2011-04-18 12:19:23 UTC
+1
Comment 4 tho48 2011-04-18 12:20:38 UTC
+1
Comment 5 Antharez 2011-04-18 12:25:50 UTC
+1
Comment 6 sorinnn 2011-04-18 12:41:11 UTC
+1
Comment 7 rocket_stefan 2011-04-18 13:15:36 UTC
+1
Comment 8 bartrail_ 2011-04-18 13:19:22 UTC
* dependency injection
Comment 9 josepminguelltorroja 2011-04-18 13:31:28 UTC
+1
Comment 10 honzamarek 2011-04-18 13:37:28 UTC
These plus ones are annoying. It spams me via e-mail notifications...
Comment 11 leszczu 2011-04-18 13:42:47 UTC
Please, use VOTE function instead of +1! Click on (vote) next to Priority field!
Comment 12 ayri 2011-04-18 14:06:40 UTC
+1
Comment 13 szymon.szewczyk 2011-04-18 18:13:18 UTC
+1
Comment 14 EmmanuelVella 2011-04-18 20:20:36 UTC
+1
Comment 15 monofone 2011-04-19 06:55:08 UTC
There is allready TWIG Support through the plugin from blogsh check his github page for downloads of the plugin.

https://github.com/blogsh/Twig-netbeans
Comment 16 sfmin 2011-04-19 10:03:01 UTC
+1
Comment 17 islautin 2011-04-19 11:07:28 UTC
+1
Comment 18 laziguana 2011-04-19 12:54:38 UTC
+1
Comment 19 dr1ss 2011-04-19 12:58:19 UTC
+1 
Netbeans would be MORE awesome with this :p
Comment 20 umpirsky 2011-04-19 13:00:28 UTC
Created attachment 107834 [details]
Vote

Please find vote instructions attached.
Comment 21 johesqpi 2011-04-19 14:33:06 UTC
+1
Comment 22 javier.acosta 2011-04-20 04:00:53 UTC
+1
Comment 23 Itako 2011-04-20 06:51:50 UTC
Are you people that retarted?
Stop spamming comment section because it's also spamming our mail boxes.
It's not a f... youtube
Comment 24 bartrail_ 2011-04-23 11:59:37 UTC
* Support for annotation definitions for config files/classes (also for orm/odm doctrine annotations)
Comment 25 spyjamesbond0072003 2011-05-25 03:20:57 UTC
+1
Comment 26 skowi 2011-06-28 14:49:46 UTC
+1
Comment 27 casivaagustin 2011-08-04 13:08:12 UTC
+1
Comment 28 makasim 2011-08-04 13:14:28 UTC
+1 

I like and use both symfony2 and NetBeans, So it would be really good to integrate symfony2.
Comment 29 AlexGalinier 2011-08-04 13:31:27 UTC
++
Comment 30 peter8500 2011-08-04 13:53:48 UTC
+1
Comment 31 jayniw 2011-08-04 14:59:17 UTC
+1
Comment 32 laziguana 2011-08-04 17:02:48 UTC
+1
Comment 33 lyrixx86 2011-08-04 17:54:23 UTC
+1
Comment 34 fariel 2011-08-04 22:13:08 UTC
*** Bug 199825 has been marked as a duplicate of this bug. ***
Comment 35 mysth 2011-08-05 09:16:09 UTC
* Twig Support
* CLI Support
Comment 36 fernandojmartin 2011-08-05 13:50:51 UTC
(In reply to comment #35)
> * Twig Support
> * CLI Support

There's a plugin for TWIG syntax. Don't have it handy now, but it's easy to find it.
Go for it! :)
Comment 37 dchart 2011-08-05 16:24:07 UTC
+1
Comment 38 pardacho 2011-08-05 18:22:25 UTC
+1 :D
Comment 39 arffak 2011-08-06 00:51:25 UTC
+1
Comment 40 pulzaraider 2011-09-04 19:06:00 UTC
I think PHPUnit support SHOULD be fixed at first!

Symfony2 have NOT global test directory. Each "bundle" (Separate part of Symfony2) has it's own test files. Current Netbeans version (7.0.1) can be configured to run these phpunit tests - see the solution http://forum.symfony-project.org/viewtopic.php?t=33543&p=114374

But it's not ideal because running one test can NOT be done with "Test" button. Only the "Run" command works ("Run all *Test files with phpunit" must be checked in project settings). 
CodeCoverage - a nice Netbeans feature - also doesn't work!

I think that PhpUnit support in Netbeans should be more configurable because maybe in the future there will be another PHP framework and Netbeans features - Code Coverage and "Test" button should work (with some sort of settings).
Comment 41 tobyhourst 2011-09-16 23:37:34 UTC
+1
Comment 42 pulzaraider 2011-10-07 09:57:59 UTC
Please create some button which will call "app\console cache:clear" command or better - some configurable batch file with this command. I'm clearing the cache after every bigger change in source code and clearing cache from IDE will be very handy.
Comment 43 jscabuzzo 2011-11-01 17:45:04 UTC
+1
Comment 44 aldogdl 2011-11-08 03:25:08 UTC
* Twig-Support
Comment 45 aldogdl 2011-11-08 03:28:02 UTC
(In reply to comment #1)
> +1
Symfony 2
Twig-Support
Comment 46 ank 2011-12-27 16:40:55 UTC
+1
Comment 47 Monomachus 2012-01-24 13:05:40 UTC
Add autocomplete for Doctrine 2 annotations like these ones

use Doctrine\ORM\Mapping as ORM;

/**
 * @ORM\Entity(repositoryClass="Blogger\BlogBundle\Repository\CommentRepository")
 * @ORM\Table(name="comment")
 * @ORM\HasLifecycleCallbacks()
 */

If I can help please show me how, or at least where to start.
Comment 48 victorberchet 2012-01-24 18:09:06 UTC
It would be very nice to have similar functionalities as what have been developed for Eclipse by Robert Gruendler (aka pulse00 on github).

Here is a link to the plugins
- homepage: http://symfony.dubture.com/
- source code: https://github.com/pulse00/Symfony-2-Eclipse-Plugin

The plugin is very useful and well documented. If am willing to help if we need to create a prioritized list of most important features.
Comment 49 hardchor 2012-01-25 09:21:05 UTC
(In reply to comment #48)
> It would be very nice to have similar functionalities as what have been
> developed for Eclipse by Robert Gruendler (aka pulse00 on github).
> 
> Here is a link to the plugins
> - homepage: http://symfony.dubture.com/
> - source code: https://github.com/pulse00/Symfony-2-Eclipse-Plugin
> 
> The plugin is very useful and well documented. If am willing to help if we need
> to create a prioritized list of most important features.

I agree, I'm almost tempted to switch over to Eclipse for Symfony2 projects. Oh dear!
Comment 50 Tomas Mysik 2012-01-25 10:38:08 UTC
In NB 7.2, there will be basic support for:
- Symfony2,
- Twig,
- Doctrine2.

The Symfony2 support itself won't be perfect but simply we do not have enough time and resources to make it excellent, sorry. Anyone interested can try the development version of NetBeans [1].

[1] http://bits.netbeans.org/download/trunk/nightly/latest/
Comment 51 Tomas Mysik 2012-01-25 10:38:59 UTC
One more link to our blog.

http://blogs.oracle.com/netbeansphp/entry/symfony2_and_twig_part_of
Comment 52 victorberchet 2012-01-25 10:49:48 UTC
Tomas,

Any idea on how difficult it would be to port the Eclipse plugin (the one mentioned in my message above) to Netbeans ?

I think a lot of people would be interested and we might be able to achieve something with the help of the community.
Comment 53 Tomas Mysik 2012-01-25 11:06:29 UTC
(In reply to comment #52)
> Any idea on how difficult it would be to port the Eclipse plugin (the one
> mentioned in my message above) to Netbeans ?

Porting the plugin is IMHO not possible. Only the same/similar functionality could be provided.

> I think a lot of people would be interested and we might be able to achieve
> something with the help of the community.

Well, this is in fact "very easy" - NetBeans is open-source so everyone is welcome. In other words, anyone can clone NetBeans sources and provide patches, we will be more than happy to accept them. The biggest problem here is that the current infrastructure is not good enough to provide a perfect support (we will need to improve mainly the PHP editor area so the frameworks can "plug" their things in it)
FAQ for NB developers can be found here [1].

Thanks.
[1] http://wiki.netbeans.org/NetBeansDeveloperFAQ
Comment 54 victorberchet 2012-01-26 10:23:52 UTC
(In reply to comment #53)

Tomas,

Thank for your replies.

With the agreement of Robert I have started a page on his plug-in wiki [1] to discuss the development of Netbeans (or cross IDE) plugin.

It seems to be good place to discuss this:

* This plug-in already provides a great set of functionalites,
* The goal would be to create an IDE agnostic base library (i.e. not only Netbeans),
* The github interface make it easy to collaborate.

The next step is to look for people willing to help. Anybody willing to help should add its name under the "Volunteers" section.

Cheers,
Victor

[1) https://github.com/pulse00/Symfony-2-Eclipse-Plugin/wiki/Netbeans-plugin
Comment 55 Tomas Mysik 2012-01-26 11:39:27 UTC
Hi Victor, thanks for your effort and for that wiki page. I have read it and I would add info about the upcoming NetBeans version (7.2) - the Symfony2 and Twig plugins are now part of it [1].

Thanks.
[1] http://blogs.oracle.com/netbeansphp/entry/symfony2_and_twig_part_of
Comment 56 dafuer 2012-02-04 10:52:36 UTC
+1
Comment 57 Tomas Mysik 2012-03-01 10:31:24 UTC
Symfony2 plugin (together with Twig plugin) is now part of NB 7.2 so closing this issue as FIXED.

Please, do not reopen this issue but submit individual bugs/enhancements instead.

Thanks.
Comment 58 devnull333 2012-05-13 18:22:09 UTC
netbeans-trunk-nightly-201205130400-ml-windows:  installation of php module failed. so i cannot test it.

what exactly is in the 7.2 symfony plugin? i only read about twig support and the sf2 plugin (http://plugins.netbeans.org/plugin/40565/php-symfony2-framework)

of corse this is nice, but please don't call this a symfony2 support.

but without:
- Codeassist for Symfony specific elements, like services, routes, template paths, entities and translations.
- Navigation: Hyperlinking of routes, templates and services
http://symfony.dubture.com/

mainly codeassist (especially for services), it is really no symfony2 support.

this is really no rant comment, i know netbeans is free, everybody can help,... but just closing the ticket "symfony2 support" without haveing a sf2 support is wrong. 

saying we should create a ticket for each feature we need and closing this ticket... well. you have a clear template what users expect from symfony support (just see eclipse)

if this features are in netbeans 7.2 just forget what i wrote above and let me say thank you.
if not, please reopen this ticket. closing this ticket sends a wrong signal to the users. currently netbeans has no symfony support, adding some commands and twig support is still no sf2 support.
Comment 59 scube 2012-06-19 07:57:52 UTC
I think exactly the same a s devnull333!

The current SF2 plugin should be just the beginning. Please have a look at http://symfony.dubture.com/ and how far they are with their SF2 plugin.

Any chance to reopen that issue or to create a new one with enhanced features?
Comment 60 Tomas Mysik 2012-06-19 08:34:03 UTC
For NetBeans 7.2, the Symfony2 support contains all the features we have planned for that release (project creation, commands, annotations, twig). Of course, we will continue working on this area to improve it for the next NetBeans releases but please notice that the resources we have, are limited.

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo