Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 196633 - [70cat] Strange behaviour after deleting project
[70cat] Strange behaviour after deleting project
Status: RESOLVED WORKSFORME
Product: java
Classification: Unclassified
Component: Project
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Jan Lahoda
issues@java
73-reviewed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-13 00:35 UTC by mperezma
Modified: 2012-10-26 13:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mperezma 2011-03-13 00:35:40 UTC
Steps to reproduce:

1. Create new project "project1" (it does not need to be under version control)
2. Create new empty package "newpackage" in project1
3. Checkout a cvs hosted project (I didn't test with other versioning systems)
4. Delete it, checking the option "Also delete sources under ... folder"
5. Try to create a JFrame (or a new java class) in newpackage of project1

At this point the new JFrame does not show in projects view, although it's shown in files view.

The only packages which seem to be affected are the empty ones in the moment of deleting the project (step 4). The non-empty packages and the new empty packages created in the project (without the need to restart the ide) does not seem to be affected.
Comment 1 Stepan Zebra 2011-03-13 11:03:19 UTC
Product Version: NetBeans IDE 7.0 RC1 (Build 201103120000)
Java: 1.6.0_22; Java HotSpot(TM) Client VM 17.1-b03
System: Linux version 2.6.32-25-generic running on i386; UTF-8; cs_CZ (nb)

Reproduced with Subversion project, can't reproduce with Mercurial project.

Checkout action isn't necessary for reproduction. If there is some versioned project already opened, simply delete that one.
Comment 2 Jan Lahoda 2011-03-14 17:23:27 UTC
Appears to be a problem in PackageViewChildren.
Comment 3 Tomas Danek 2012-10-26 13:47:00 UTC
not able to reproduce with SVN project...

Product Version: NetBeans IDE 7.2.1 (Build 201210100934)
Java: 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02
System: Mac OS X version 10.8.2 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.2.1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.2.1

mperezma, are you able to reproduce with current release of NB?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo