Bug 196521 - IllegalArgumentException: Parameter file was not normalized. Was /home/as204739/devarea/projects/mysql-5.1.30/./confPEyI8G instead of /home/as204739/devarea/projects/mysql-5.1.30/confPEyI8G
IllegalArgumentException: Parameter file was not normalized. Was /home/as2047...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT
: 70_HR_FIX
: 196535 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-09 21:14 UTC by Alexander Simon
Modified: 2011-03-18 15:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.20 KB, text/plain)
2011-03-09 21:15 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2011-03-09 21:14:56 UTC
Build: NetBeans IDE Dev (Build 110309-dcfda59af53a)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
alexvsimon: reconfigure mysql




Stacktrace: 
java.lang.IllegalArgumentException: Parameter file was not normalized. Was /home/as204739/devarea/projects/mysql-5.1.30/./confPEyI8G instead of /home/as204739/devarea/projects/mysql-5.1.30/confPEyI8G
   at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:1012)
   at org.netbeans.modules.cnd.makeproject.api.configurations.Folder.fileFolderCreated(Folder.java:1109)
   at org.netbeans.modules.cnd.makeproject.api.configurations.Folder.fileFolderCreated(Folder.java:1127)
   at org.openide.filesystems.DeepListener.fileFolderCreated(DeepListener.java:127)
   at org.openide.filesystems.DeepListener.fileFolderCreated(DeepListener.java:119)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectKeeper.fileFolderCreated(FileObjectKeeper.java:261)
Comment 1 Alexander Simon 2011-03-09 21:15:00 UTC
Created attachment 106864 [details]
stacktrace
Comment 2 Alexander Simon 2011-03-09 22:20:16 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/ce8c19a30d5d
Comment 3 Quality Engineering 2011-03-10 09:35:59 UTC
Integrated into 'main-golden', will be available in build *201103100400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ce8c19a30d5d
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed Bug #196521 - IllegalArgumentException: Parameter file was not normalized.
Comment 4 Alexander Simon 2011-03-10 11:00:17 UTC
QA, please, verify fix
Comment 5 Vladimir Kvashin 2011-03-10 11:31:28 UTC
It's too early to verify this: additional fix is needed.
Comment 6 Vladimir Voskresensky 2011-03-10 12:56:43 UTC
*** Bug 196535 has been marked as a duplicate of this bug. ***
Comment 7 Vladimir Kvashin 2011-03-10 13:34:05 UTC
Additional fix is pushed to cnd-main
http://hg.netbeans.org/cnd-main/rev/5288f673a0aa

QA, could you verify the fix please.
Comment 8 soldatov 2011-03-15 11:32:08 UTC
Verified
I checked "reconfigure mysql" some times and I don't see any exception in NetBeans 7.0RC1
Comment 9 soldatov 2011-03-15 11:34:10 UTC
Sorry. I can't reproduce exception in NetBeans IDE Dev (Build cnd-main-5537-on-110315)
Comment 10 soldatov 2011-03-15 12:30:03 UTC
Verified in latest dev build
Comment 11 Vladimir Kvashin 2011-03-16 17:17:47 UTC
Code is reviewed together with Alexander Simon
Comment 12 Vladimir Kvashin 2011-03-16 18:13:59 UTC
changesets in releases branch:
http://hg.netbeans.org/releases/rev/69188954af66
http://hg.netbeans.org/releases/rev/5e90d5170bad
Comment 13 soldatov 2011-03-18 15:54:40 UTC
Verified in NetBeans IDE 7.0 RC1 (Build 201103180000)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo