Bug 196302 - Changing tool collection in full remote project hide sources and break code model
Changing tool collection in full remote project hide sources and break code m...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0
PC Windows 7 x64
: P1 (vote)
: 7.0
Assigned To: Vladimir Kvashin
issues@cnd
FULL_REMOTE
: 70_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-04 14:14 UTC by Alexander Pepin
Modified: 2011-03-17 16:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Fix prototype (6.35 KB, patch)
2011-03-14 10:44 UTC, Vladimir Kvashin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2011-03-04 14:14:44 UTC
Prerequisite - create a makefile based project on some Solaris host using "OSS
express" or "GNU" tool collection

Steps to reproduce:
- add the remote host
- import the project
- open project properties, tool collection is set to "OSS (default)" instead of tool collection chosen in the original project!!!
- choose  "OSS express" or "GNU" tool collection like in the original project and press OK
Result: Warning window with a message that access to some file denied may appear. Source folder disappears and the code model gets broken (system includes can not be found any more).
Comment 1 Vladimir Kvashin 2011-03-04 18:46:37 UTC
I believe this is fixed by
http://hg.netbeans.org/cnd-main/rev/409f140fce69
Comment 2 Quality Engineering 2011-03-06 05:40:42 UTC
Integrated into 'main-golden', will be available in build *201103060000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/409f140fce69
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixing #196302 - Changing tool collection in full remote project hide sources and break code model
Comment 3 Alexander Pepin 2011-03-11 12:05:48 UTC
It's still reproducible on Windows.
Comment 4 Vladimir Kvashin 2011-03-11 13:57:16 UTC
I was finally able to reproduce this.
Comment 5 Vladimir Kvashin 2011-03-14 10:44:28 UTC
Created attachment 106972 [details]
Fix prototype

The reason is understood, here is the proposed fix.
However I need to review and test it prior than pushing.
Comment 6 Vladimir Kvashin 2011-03-15 07:44:35 UTC
Fixed in cnd-main:
http://hg.netbeans.org/cnd-main/rev/0c6dc46145ed
Comment 7 Alexander Pepin 2011-03-15 14:12:56 UTC
verified in dev build #4974
Comment 8 Alexander Simon 2011-03-15 17:50:09 UTC
Change set 0c6dc46145ed correct and safe.
Comment 9 Quality Engineering 2011-03-16 09:42:58 UTC
Integrated into 'main-golden', will be available in build *201103160400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0c6dc46145ed
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fix for #196302 - Changing tool collection in full remote project hide sources and break code model
Comment 10 Vladimir Kvashin 2011-03-16 18:44:12 UTC
Changesets integrated to release70:
http://hg.netbeans.org/releases/rev/c38b3f498667
Comment 11 Alexander Pepin 2011-03-17 16:49:14 UTC
verified in RC1 build 20110317


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo