Bug 196007 - Unable to start embedded HTTP server
Unable to start embedded HTTP server
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: GWT
6.x
PC Other
: P3 (vote)
: TBD
Assigned To: issues@javaee
issues@javaee
http://sinati.com
: PERFORMANCE, PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-25 14:51 UTC by drecute
Modified: 2016-07-07 08:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description drecute 2011-02-25 14:51:32 UTC
I will like to say that I have added the -javaagent option to the JVM argument in my project properties but I still get this exception over and over again. i am using the "Run GWT Dev mode on App Engine" option to run the application.

java.lang.RuntimeException: Unable to locate the App Engine agent. Please use dev_appserver, KickStart,  or set the jvm flag: "-javaagent:<sdk_root>/lib/agent/appengine-agent.jar"
        at com.google.appengine.tools.development.DevAppServerFactory.testAgentIsInstalled(DevAppServerFactory.java:102)
        at com.google.appengine.tools.development.DevAppServerFactory.createDevAppServer(DevAppServerFactory.java:77)
        at com.google.appengine.tools.development.DevAppServerFactory.createDevAppServer(DevAppServerFactory.java:38)
        at com.google.appengine.tools.development.gwt.AppEngineLauncher.start(AppEngineLauncher.java:106)
        at com.google.gwt.dev.DevMode.doStartUpServer(DevMode.java:431)
        at com.google.gwt.dev.DevModeBase.startUp(DevModeBase.java:1053)
        at com.google.gwt.dev.DevModeBase.run(DevModeBase.java:795)
        at com.google.gwt.dev.DevMode.main(DevMode.java:282)
Caused by: java.lang.NoClassDefFoundError: com/google/appengine/tools/development/agent/AppEngineDevAgent
        at com.google.appengine.tools.development.DevAppServerFactory.testAgentIsInstalled(DevAppServerFactory.java:98)
        ... 7 more
Caused by: java.lang.ClassNotFoundException: com.google.appengine.tools.development.agent.AppEngineDevAgent
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
        ... 8 more
Comment 1 Martin Balin 2016-07-07 08:53:27 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo