Bug 195970 - IDE window grabs focus whenever any running app exits on OSX
IDE window grabs focus whenever any running app exits on OSX
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
6.x
Macintosh (x86) Mac OS X
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 22:03 UTC by johansensen
Modified: 2011-03-01 19:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johansensen 2011-02-24 22:03:16 UTC
Whenever any application quits, either by being manually terminated or terminating itself, the IDE brings itself to the foreground and grabs focus. This is understandably frustrating when one usually has it at the bottom of a stack of windows and it keeps jumping to the top.

Perhaps this is mishandling some sort of OS event or callback?

Hardware Overview:

  Model Name:	MacBook
  Model Identifier:	MacBook5,2
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	3 MB
  Memory:	4 GB
  Bus Speed:	1.07 GHz
  Boot ROM Version:	MB52.0088.B05
  SMC Version (system):	1.38f5
  Serial Number (system):	4591166N4R1
  Hardware UUID:	F3463F54-1654-5E42-8AF6-333B65F5E833
  Sudden Motion Sensor:
  State:	Enabled

Running OSX 10.6.6
Comment 1 Stanislav Aubrecht 2011-03-01 15:16:26 UTC
can't reproduce with:
Product Version: NetBeans IDE 6.9.1 (Build 201011082200)
Java: 1.6.0_22; Java HotSpot(TM) 64-Bit Server VM 17.1-b03-307
System: Mac OS X version 10.6.6 running on x86_64; MacRoman; en_US (nb)


reporter, is this reproducible with a clean user dir? do you have any third party plugins installed?
Comment 2 johansensen 2011-03-01 19:51:28 UTC
No third party plugins, but emptying user dir resolved this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo