Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195936 - Cannot run project containing national chars
Cannot run project containing national chars
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.0
All All
: P2 (vote)
: 7.0
Assigned To: Jaromir Uhrik
issues@platform
fix-in-nb701,jdk_bug_7025874,jdk_bug_...
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 11:09 UTC by Jaromir Uhrik
Modified: 2011-06-09 07:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot attached... (64.56 KB, image/png)
2011-02-24 11:09 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2011-02-24 11:09:44 UTC
Created attachment 106402 [details]
Screenshot attached...

Product Version: NetBeans IDE Dev (Build 201102240001)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b02
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)

This is reproducible only on JDK7 (on JDK6u23 works fine).

Steps to reproduce:
-create new j2se project with name containing some e.g. czech character or just create a java class with name containing such a character.

-->> It is not possible to run the project or class containing national chars
Comment 1 Tomas Zezula 2011-03-08 16:04:02 UTC
It's JDK bug in Runtime.exec() on Windows. On Linux works fine.
Comment 2 Tomas Zezula 2011-03-08 16:49:47 UTC
Works fine on JDK 1.6 (1.6.0_24)
Comment 3 Tomas Zezula 2011-03-08 17:47:42 UTC
It's not problem of Runtime.exec but the problem in the java launcher. When Runtime.exec start JDK 1.6 VM it works fine.

Also running following from cmd line works fine:
"C:\Program Files\Java\jdk1.6.0_24\bin\java.exe" -cp build\classes xxššaa.Xxššaa
while running the samw with JDK 7.0 does not

I will create a JDK bug
Comment 4 Tomas Zezula 2011-03-08 18:05:12 UTC
Sorry Jardo.
I haven't found a suitable category for java launcher in http://bugreport.sun.com/bugreport.
Can you submit the bug yourself, anyway you have found it? ;-)

The summary is:
The problem happens on Windows with JDK 1.7. On JDK 1.6 u 24 it works fine.
The problem is that the launcher corrupts national characters.
Way to reproduce from cmd line:
1) Create a class xxššaa.Xxššaa in your project and build the project.
2) In the cmd line run: java.exe -cp build\classes xxššaa.Xxššaa
when the java is JDK 1.6 it works fine and class is executed when it's JDK 1.7 it crashes.
Comment 5 Jaromir Uhrik 2011-03-09 10:45:20 UTC
I filed an issue number 7025874 against JDK.
Comment 6 Tomas Danek 2011-03-09 12:19:53 UTC
can we close it once we have JDK bug entered?
Comment 7 Tomas Danek 2011-03-09 12:26:07 UTC
Must be fixed on JDK side.
Comment 8 Jan Lahoda 2011-03-20 20:01:06 UTC
Bug #7025874 has been closed as a duplicate of #7026184, for which a fix has been committed to the JDK7/tl repository:
http://hg.openjdk.java.net/jdk7/tl/jdk/rev/90f84ecff75c
Comment 9 Marian Mirilovic 2011-06-08 18:33:34 UTC
verified in 
Product Version: NetBeans IDE 7.0.1 Dev (Build 201106072116)
Java: 1.7.0-ea; Java HotSpot(TM) 64-Bit Server VM 21.0-b15


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo