Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195925 - Multilevel code folding (if, for, do, while, switch)
Multilevel code folding (if, for, do, while, switch)
Status: RESOLVED DUPLICATE of bug 186731
Product: php
Classification: Unclassified
Component: Editor
7.0
All All
: P1 with 6 votes (vote)
: TBD
Assigned To: Ondrej Brejla
issues@php
:
: 172617 (view as bug list)
Depends on:
Blocks: 142074
  Show dependency treegraph
 
Reported: 2011-02-24 08:23 UTC by jcrada
Modified: 2014-06-06 06:38 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jcrada 2011-02-24 08:23:23 UTC
Please, implement multilevel code folding to enable foldings of statements as if, for, while, switch, and others in all languages (or at least C++ and Java)
Comment 1 jcrada 2011-02-24 08:23:45 UTC
*** Bug 172617 has been marked as a duplicate of this bug. ***
Comment 2 jkuliak 2011-08-02 19:47:32 UTC
Perhaps this should be merged into Bug 186731 ? Also that bug should be for all languages, not just php.
Comment 3 faramir2 2011-10-26 10:20:24 UTC
+1.

It would be nice to have if-else,try-catch-finally,switch,case and others folding possibilities. Every "{ (...) }" could be folded.
What is folded could be changed in options.
Comment 4 Aweb 2011-12-01 09:39:56 UTC
This feature would be very useful for me, aprticularly in PHP where I use enormous switch() statements.
Comment 5 Svata Dedic 2012-05-28 14:40:57 UTC
Moving to PHP. The folding infrastructure already supports multiple levels, actual fold providers are tied to language (PHP in this case).
Comment 6 Ondrej Brejla 2012-09-04 15:39:16 UTC

*** This bug has been marked as a duplicate of bug 186731 ***
Comment 7 ricktw 2014-06-06 06:38:18 UTC
multilevel code folding for Java has been moved to bug 222493


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo