Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195645 - Not possible to install to non default JDK location
Not possible to install to non default JDK location
Status: CLOSED WORKSFORME
Product: installer
Classification: Unclassified
Component: JDK bundle
6.x
PC Windows XP
: P2 (vote)
: 7.0
Assigned To: Yulia Novozhilova
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-18 08:48 UTC by Jiri Skrivanek
Modified: 2011-03-18 08:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-02-18 08:48:41 UTC
If you change default JDK installation location it is not filled in "JDK for the NetBeans IDE" in next page and the Next button in the wizard is disabled because it doesn't find JDK. To reproduce:

- start installer
- change "Install the JDK to:" to a non default location
- click next
- the field "JDK for the NetBeans IDE" is empty but it should contain previously selected JDK location. Even if you specify JDK location defined in previous page, it is not possible to continue because the Next button is disabled with message "The specified JDK folder ... does not contain JDK."

jdk-6u24-nb-6_9_1-windows-ml.exe
Comment 1 Yulia Novozhilova 2011-03-10 16:09:35 UTC
Jiri,
I can not reproduce your issue. What jdk installation location did you choose? Could you please attach installer log file here ($USERDIR\.nbi\log\*.log)?
Comment 2 Jiri Skrivanek 2011-03-11 10:49:50 UTC
Yulia, now it works for me as well. I am sorry for false alarm.
Comment 3 Marian Mirilovic 2011-03-18 08:44:40 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo