Bug 195297 - Change of visibility of a FileObject is not reflected
Change of visibility of a FileObject is not reflected
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Data Systems
7.0
PC Linux
: P2 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-10 15:20 UTC by Petr Pisl
Modified: 2011-02-16 11:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2011-02-10 15:20:30 UTC
The files with ~ are ignored by the IDE by default and are not visible. If such FileObject is renamed (through an code), its visibility is changed correctly, but it's not reflected by the IDE. 

In PHP there is an action that downloads files from an FTP server. The downloaded file is saved into a folder that is opened in the project explorer and the new file is saved for example as index.php.new~ . When whole file is downloaded, then the file is renamed to index.php. The problem is that the appropriate node is not displayed in the explorer after the action.

When I remove ~ from Tools->Options->Miscellaneous->Files->Ignored Files Pattern, that the download action works correctly. So it looks like the change of visibility is not reflected in the explorer. 

This works in NetBeans 6.9.

See issue #195141
Comment 1 Jaroslav Tulach 2011-02-11 10:29:35 UTC
According to this test the filesystem changes are correctly reflected in nodes (and thus explorer):
http://hg.netbeans.org/ergonomics/rev/3462aedbb6de
Comment 2 Quality Engineering 2011-02-16 11:42:21 UTC
Integrated into 'main-golden', will be available in build *201102160501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3462aedbb6de
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #195297: Verifying that change in visibility is reflected in FolderChildren


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo