Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 195279 - Code completion blocked by PHP lexing
Code completion blocked by PHP lexing
Status: RESOLVED DUPLICATE of bug 194222
Product: php
Classification: Unclassified
Component: Smarty
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Martin Fousek
issues@php
: PERFORMANCE
Depends on:
Blocks: 179727
  Show dependency treegraph
 
Reported: 2011-02-10 09:57 UTC by Jaroslav Tulach
Modified: 2011-09-06 10:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2011-02-10 09:57:34 UTC
Look at
http://statistics.netbeans.org/exceptions/exception.do?id=453942

the code completion seems to be blocked in org.netbeans.editor.BaseKit$InsertBreakAction.performLineBreakInsertion()
by many calls to 
org.netbeans.lib.lexer.TextLexerInputOperation.readExisting()
via
org.netbeans.modules.php.smarty.editor.lexer.TplTopLexer.nextToken()
Comment 1 Ondrej Brejla 2011-08-24 08:50:32 UTC
Smarty related -> reassigning
Comment 2 Martin Fousek 2011-08-25 12:50:47 UTC
Thanks a lot for reporting that, already fixed.

*** This bug has been marked as a duplicate of bug 194222 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo