Bug 195254 - Create new projects without a test folder
Create new projects without a test folder
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
7.0
All All
: P1 (vote)
: 7.0
Assigned To: David Konecny
issues@javaee
junitlib
:
: 195964 (view as bug list)
Depends on: 196597
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-09 21:33 UTC by Jesse Glick
Modified: 2011-03-11 16:00 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-02-09 21:33:03 UTC
Due to the fix of bug #102711 the test folder will be created on demand for an Ant-based project when first adding a unit test via wizard. There is no need to add JUnit library dependencies to the project since those will be added by the JUnit wizards. You do need the define the test root and its location in project.{xml,properties} - just don't actually make the folder.
Comment 1 Jesse Glick 2011-02-10 00:41:09 UTC
Done for j2seproject's. (Class Library & Application, sharable or not; From Existing Sources if no test folders specified.) Did not bother doing it for "Desktop Application" which is semideprecated anyway. Needs to be done for EE project types. core-main #de5b8655fc3d
Comment 2 Quality Engineering 2011-02-10 11:29:58 UTC
Integrated into 'main-golden', will be available in build *201102100500* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/de5b8655fc3d
User: Jesse Glick <jglick@netbeans.org>
Log: #195254: when creating a new project, do not give it a test folder or JUnit dependencies.
Comment 3 David Konecny 2011-02-16 21:30:13 UTC
Done for EE project types: 33cf725b7471
Comment 4 Quality Engineering 2011-02-17 11:00:23 UTC
Integrated into 'main-golden', will be available in build *201102170501* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/33cf725b7471
User: David Konecny <dkonecny@netbeans.org>
Log: #195254 - Create new projects without a test folder
Comment 5 David Konecny 2011-02-24 19:48:49 UTC
*** Bug 195964 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo