Bug 194214 - SQL Command execution output window loses focus
SQL Command execution output window loses focus
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
PC Windows XP
: P3 (vote)
: 7.2
Assigned To: Jiri Rechtacek
issues@db
: FOCUS
: 194208 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-11 11:58 UTC by tilman
Modified: 2012-05-21 08:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tilman 2011-01-11 11:58:40 UTC
After clicking "Run SQL" to run a successful SQL command, the "SQL
Command execution" window that is part of the "output" group loses
focus, and my "Apache Tomcat 6.0.26 Log" window is shown instead. 
This is kindof weird.

If an SQL command is unsuccessful, then the "SQL Command execution"
window is shown, which is the way it should be.

IMHO the correct behaviour should be:
- if the "SQL Command execution" window doesn't exist, show it
- if the "SQL Command execution" window exists and has the focus, keep
it
- if the "SQL Command execution" window exists and hasn't the focus,
show it either (a) immediately, or (b) when the SQL command is done, or
(c) when the SQL command has failed. (I'm not sure which of these
alternatives is the best, although I notice that the "dist" output
window is shown immediately when doing a project build, which is like my
(a) option)
Comment 1 Jiri Rechtacek 2011-01-21 08:18:06 UTC
*** Bug 194208 has been marked as a duplicate of this bug. ***
Comment 2 Jaroslav Havlin 2012-05-21 08:33:39 UTC
Related to bug 200302. Seems to work fine now.
Please reopen if some problems remain. Thank you.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo