Bug 193626 - RESTful WS from DB ( or entities ) doesn't work with Spring 3
RESTful WS from DB ( or entities ) doesn't work with Spring 3
Status: RESOLVED FIXED
Product: usersguide
Classification: Unclassified
Component: Web tutorials
6.x
PC Windows XP
: P3 (vote)
: 7.0
Assigned To: Jeffrey Rubinoff
issues@usersguide
:
: 195547 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-20 07:53 UTC by Denis Anisimov
Modified: 2011-02-16 14:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Anisimov 2010-12-20 07:53:19 UTC
- Create Jee5 Web Project .
- Generate RESTful from DB.
- Deploy project on J2EE server ( I have used GF2 ).

There is a runtime exception :
Unexpected exception parsing XML document from ServletContext resource [/WEB-INF/applicationContext.xml]; nested exception is java.lang.NoClassDefFoundError: org/aopalliance/intercept/MethodInterceptor

The cause of this exception is aopalliance.jar absence in the classpath .
This is the url of the library : http://sourceforge.net/projects/aopalliance/files/aopalliance/1.0/
Comment 1 Denis Anisimov 2010-12-20 08:03:35 UTC
Addition :
I forgot to mention that Project should be created with Spring framework.
Comment 2 Petr Jiricka 2010-12-22 20:27:43 UTC
I am able to reproduce (with GF 3.1 Promoted Build).
Comment 3 Denis Anisimov 2010-12-23 08:59:19 UTC
changeset:   185073:ee7c4cafb7b1
user:        Denis Anisimov <ads@netbeans.org>
date:        Thu Dec 23 11:55:25 2010 +0300
summary:     Fix for BZ#193626 -  RESTful WS from DB ( or entities ) doesn't work with Spring 3
Comment 4 Quality Engineering 2010-12-29 07:09:42 UTC
Integrated into 'main-golden', will be available in build *201012290001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ee7c4cafb7b1
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#193626 -  RESTful WS from DB ( or entities ) doesn't work with Spring 3
Comment 5 Jeffrey Rubinoff 2011-02-16 12:17:11 UTC
Documentation, particularly the Getting Started With RESTful Web Services tutorial, must reflect this.
Comment 6 Jeffrey Rubinoff 2011-02-16 12:20:21 UTC
*** Bug 195547 has been marked as a duplicate of this bug. ***
Comment 7 Jeffrey Rubinoff 2011-02-16 14:01:50 UTC
Revision: 11625
Author:   jeff_rubinoff
Date:     2011-02-16 15:01
Message:  added instructions for adding aopalliance.jar to Spring applications
Issue #193626 - RESTful WS from DB ( or entities ) doesn't work with Spring 3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo