Bug 193485 - Bug in Macro playback
Bug in Macro playback
Status: RESOLVED DUPLICATE of bug 199695
Product: editor
Classification: Unclassified
Component: Macros
7.0
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Svata Dedic
issues@editor
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 11:21 UTC by riggerthegeek
Modified: 2011-10-10 12:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description riggerthegeek 2010-12-16 11:21:28 UTC
Product Version = NetBeans IDE 7.0 Beta (Build 201011152355)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_22
Runtime = Java HotSpot(TM) Client VM 17.1-b03

I've found a bug in Macro playback.  I have recorded various Macros - one in particular is {echo '<pre>.print_r($, true).'</pre>';exit;} for PHP debug.  This prints correctly, but it doesn't move the cursor back to immediately after the dollar ($) sign as it did on NB 6.9.  The cursor ends up either at the end of the line or at the start of the line.

Not really found a common cause as to where it ends up, but it doesn't end up where it should.

The full Macro is below

"echo '<pre>'.print_r($, true).'</pre>';exit;" caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-backward caret-forward
Comment 1 Svata Dedic 2011-10-10 12:45:24 UTC

*** This bug has been marked as a duplicate of bug 199695 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo