Bug 193066 - Cannot log in using "Delegate to servlet container" authentication
Cannot log in using "Delegate to servlet container" authentication
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Hudson
7.0
PC Linux
: P3 (vote)
: 7.2
Assigned To: Jesse Glick
issues@connecteddeveloper
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-08 20:11 UTC by _ rkubacki
Modified: 2012-05-05 10:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
hudson module logging (4.42 KB, text/plain)
2010-12-08 20:11 UTC, _ rkubacki
Details
server.xml configuration file (6.61 KB, application/xml)
2010-12-09 14:53 UTC, Max Sauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2010-12-08 20:11:00 UTC
Created attachment 103755 [details]
hudson module logging

Product Version: NetBeans IDE Dev (Build 201011300001)
Java: 1.6.0_22; Java HotSpot(TM) Server VM 17.1-b03
System: Linux version 2.6.35-23-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/radim/src/chemaxon/trunk_userdir

Hudson ver. 1.367 running remotely.

I cannot add our Hudson server to IDE (using correct authentication data). I'll attach relevant part of log and help you to track it down - just let me know what kind of information you need.
Comment 1 Jesse Glick 2010-12-08 20:27:24 UTC
I need to know how to reproduce the problem on my own. The IDE log just says that the server rejected the login attempt with a 403, not why. The server log might say why (or not).

And first try with a dev build where bug #193008 is fixed.
Comment 2 _ rkubacki 2010-12-08 20:33:09 UTC
OK. I'll wait for build with a fix for bug#130008. If it does not help we can discuss how to make that reproducible for you. Thanks.
Comment 3 _ rkubacki 2010-12-09 09:50:17 UTC
I checked with 201012090001 build and the problem persists. I'll look for a way how to make it reproducible for you.
Comment 4 Max Sauer 2010-12-09 10:27:07 UTC
I've just tried and it only does not work when "Access Control|Security realm" is set to "Delegate to servlet container" in hudson settings. "Hudson's own user database" works OK (I can register hudson without problems then). We're using tomcat-6.0.29.
Comment 5 Jesse Glick 2010-12-09 13:57:01 UTC
Strange, this is supposed to work; j_acegi_security_check will fail as expected, but then the IDE tries to log in using "legacy mode" via j_security_check. In your case that produces a 400 "bad request", which is certainly unexpected. Is there no mention of this in either the Hudson or Tomcat logs?

When I get a couple of hours free I will try to set up Tomcat with security and see if I can reproduce it. If so, can use e.g. curl to simulate all the HTTP transactions involved in a successful login. Do you have any instructions available for reproducing in a clean Tomcat/Hudson installation? (Max are you working on the same server as Radim?) Otherwise I will have to guess at the various configuration parameters for Tomcat, which can get complicated.
Comment 6 Max Sauer 2010-12-09 14:53:43 UTC
Created attachment 103870 [details]
server.xml configuration file
Comment 7 Max Sauer 2010-12-09 15:04:03 UTC
I've uploaded our server.xml file, tomcat-users looks like this:

<tomcat-users>
  <role rolename="manager"/>
  <role rolename="tomcat"/>
  <role rolename="admin"/>
  <role rolename="role1"/>
  <user username="jesse" password="glick" roles="admin"/>
</tomcat-users>

There is no additional special setup. Hudson 1.367, tomcat-6.0.29 with loaded war. Access Control|Security realm"
is set to "Delegate to servlet container". Authorization is "Matrix based security". You should be able to log in using jesse/glick.

I haven't found anything special in either tomcat or hudson log. Same server as Radim.
Comment 8 Jesse Glick 2012-05-04 03:12:30 UTC
core-main #5c3cb7fb60fe
Comment 9 Quality Engineering 2012-05-05 10:20:18 UTC
Integrated into 'main-golden', will be available in build *201205050400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5c3cb7fb60fe
User: Jesse Glick <jglick@netbeans.org>
Log: #193066: Cannot log in using "Delegate to servlet container" authentication


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo