Bug 192607 - Editor fails to dedent
Editor fails to dedent
Status: RESOLVED DUPLICATE of bug 192098
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows 7 x64
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-28 21:29 UTC by darkest_fright
Modified: 2010-11-29 08:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darkest_fright 2010-11-28 21:29:54 UTC
After installing patch 2, the Java editor fails to dedent braces for control stuctures and method bodies.

For example: when I type:

if(boolean_expression)
     doSomething()

it works correctly.  Before the patch, if I wanted doSOmething() to be in a code-block the editor would automatically adjust the indent to match the identation level of the if-statement:

if(boolean_expression)
{

Currently, it does this instead:

if(boolean_expression)
    {

Even after pressing enter, the editor fails to adjust it so I am left with:

if(boolean_expression)
    {

}
Comment 1 Dusan Balek 2010-11-29 08:51:15 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 192098 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo