Bug 192604 - last } does not get to it's right place
last } does not get to it's right place
Status: RESOLVED DUPLICATE of bug 192098
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-28 19:16 UTC by Mr.Axe
Modified: 2010-11-29 09:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mr.Axe 2010-11-28 19:16:39 UTC
after typing
[code]
if ( a>b ) {
    statement 1;
    statement 2;
    <------------- cursor standing here
[/code]

I press "}" in this moment and I get:

[code]
if ( a>b ) {
    statement 1;
    statement 2;
    }
[/code]

Some time ago in the same situations I always got: 
[code]
if ( a>b ) {
    statement 1;
    statement 2;
}
[/code]
Brace must automatically take the right position, but it doesn't
Comment 1 Dusan Balek 2010-11-29 09:07:48 UTC
Already fixed in the current dev build.

*** This bug has been marked as a duplicate of bug 192098 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo