Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 191211 - [69cat] java.io.FileNotFoundException: C:\Users\Javier\Documents\NetBeansProjects\Xinco\XincoWebApp\nbproject\jax-ws.xml (The system cannot find the file specified)
[69cat] java.io.FileNotFoundException: C:\Users\Javier\Documents\NetBeansProj...
Status: RESOLVED DUPLICATE of bug 190462
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
All All
: P3 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-21 12:17 UTC by javydreamercsw
Modified: 2010-11-24 20:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.42 KB, text/plain)
2010-10-21 12:18 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2010-10-21 12:17:57 UTC
Build: NetBeans IDE 7.0 M2 (Build 201010151251)
VM: Java HotSpot(TM) Client VM, 17.0-b17, Java(TM) SE Runtime Environment, 1.6.0_21-b07
OS: Windows 7

User Comments:
javydreamercsw: Opening a project




Stacktrace: 
java.io.FileNotFoundException: C:\Users\Javier\Documents\NetBeansProjects\Xinco\XincoWebApp\nbproject\jax-ws.xml (The system cannot find the file specified)
   at java.io.FileInputStream.open(FileInputStream.java:0)
   at java.io.FileInputStream.<init>(FileInputStream.java:106)
   at java.io.FileReader.<init>(FileReader.java:55)
   at org.netbeans.modules.websvc.api.jaxws.project.WSUtils.hasClients(WSUtils.java:599)
   at org.netbeans.modules.websvc.core.jaxws.projects.JavaEEWSOpenHook.projectOpened(JavaEEWSOpenHook.java:115)
   at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:84)
Comment 1 javydreamercsw 2010-10-21 12:18:03 UTC
Created attachment 102542 [details]
stacktrace
Comment 2 Denis Anisimov 2010-10-22 07:39:00 UTC
This exception is not consequence of error in IDE .
This is result of external modification of the project.

jax-ws.xml file was deleted between two invocations in the source code:
successful finding this file on FS and access to this file for its read.
Some external process deletes jax-ws.xml at the same time when project opens.

If you are able to reproduce this bug then please provide exact steps of 
reproduction.
Comment 3 javydreamercsw 2010-10-22 11:58:21 UTC
Steps to replicate:

1. Check out source from: https://xinco.svn.sourceforge.net/svnroot/xinco/trunk
2. Open the XincoWebApp project and all related projects
3. Close the 3 projects
4. With the IDE still open delete the downloaded projects and in the same place
check out from: https://xinco.svn.sourceforge.net/svnroot/xinco/branches/2.0
5. Open the XincoWebApp project and all related projects

In the scenario above it seems to be some cache issues as the project still
shows the jar dependencies from the project on step 1.

This happened at the same time issue #191211 happened. They might be related.
Comment 4 Denis Anisimov 2010-10-22 12:24:31 UTC
Thanks for detailed steps of reproduction.
It really looks like some cache problem.
But this is not WS bug.

There are two calls :
FileObject fileObject = project.getProjectDirectory().getFileObject()
and 
if ( fileObject!=null) {
    File file = FileUtil.toFile(fileObject);
    // read file
}

variable file equals null .
But it should not be because is in case of file absence previous call 
for FileObject should return null.

Reassign to filesystem functionality.
Comment 5 Jaroslav Tulach 2010-11-24 20:14:40 UTC
Probably related to the fact that right now the state in the memory is not updated automatically with the real state on the disk.

*** This bug has been marked as a duplicate of bug 190462 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo