Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 189214 - NullPointerException at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateNewLineOffset
NullPointerException at org.netbeans.modules.editor.lib2.view.HighlightsViewF...
Status: RESOLVED DUPLICATE of bug 189608
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P3 (vote)
: 7.0
Assigned To: issues@editor
issues@editor
linewrap
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 15:56 UTC by Tomas Mysik
Modified: 2010-08-26 12:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.59 KB, text/plain)
2010-08-04 15:56 UTC, Tomas Mysik
Details
stacktrace (4.61 KB, text/plain)
2010-08-11 12:05 UTC, Tomas Stupka
Details
stacktrace (3.13 KB, text/plain)
2010-08-12 13:08 UTC, Peter Pis
Details
stacktrace (4.49 KB, text/plain)
2010-08-12 13:20 UTC, Peter Pis
Details
stacktrace (2.77 KB, text/plain)
2010-08-16 16:32 UTC, Jan Lahoda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2010-08-04 15:56:16 UTC
Build: NetBeans IDE Dev (Build 100801-3547a4cb9429)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Linux

User Comments:
tmysik: Invoked View Difference action in test runner UI for PHP unit tests




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateNewLineOffset(HighlightsViewFactory.java:210)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.createView(HighlightsViewFactory.java:165)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createNextView(ViewBuilder.java:350)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createViews(ViewBuilder.java:291)
   at org.netbeans.modules.editor.lib2.view.ViewUpdates.initChildren(ViewUpdates.java:162)
   at org.netbeans.modules.editor.lib2.view.DocumentView.initChildren(DocumentView.java:473)
Comment 1 Tomas Mysik 2010-08-04 15:56:21 UTC
Created attachment 101202 [details]
stacktrace
Comment 2 Tomas Stupka 2010-08-11 12:05:12 UTC
Created attachment 101314 [details]
stacktrace

o.n.e.linewrap=true
scrolled around in a javafile
Comment 3 Exceptions Reporter 2010-08-11 19:17:13 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=171521
Comment 4 Peter Pis 2010-08-12 13:08:17 UTC
Created attachment 101339 [details]
stacktrace

Acception former difference version of the file via editable diff.
Comment 5 Peter Pis 2010-08-12 13:20:17 UTC
Created attachment 101341 [details]
stacktrace
Comment 6 Miloslav Metelka 2010-08-13 08:15:42 UTC
It's some sort of race condition, I have added some additional checks to better diagnose the problem:
http://hg.netbeans.org/jet-main/rev/5292b6055377
Comment 7 Jan Lahoda 2010-08-16 16:32:32 UTC
Created attachment 101424 [details]
stacktrace
Comment 8 Quality Engineering 2010-08-17 03:14:18 UTC
Integrated into 'main-golden', will be available in build *201008170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5292b6055377
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #189214 - NullPointerException at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateNewLineOffset - added some extra checks to diagnose problem.
Comment 9 Miloslav Metelka 2010-08-26 12:31:40 UTC
This problem will no longer occur since in fact it morphed into issue #189608 so closing this one as dup.

*** This bug has been marked as a duplicate of bug 189608 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo