Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 189021 - NullPointerException at org.netbeans.modules.debugger.jpda.models.ArgumentObjectVariable.<init>
NullPointerException at org.netbeans.modules.debugger.jpda.models.ArgumentObj...
Status: VERIFIED DUPLICATE of bug 186349
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT
:
: 189067 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 14:40 UTC by Alexandr Scherbatiy
Modified: 2010-08-05 09:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.93 KB, text/plain)
2010-07-28 14:40 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2010-07-28 14:40:25 UTC
This issue was reported manually by sunflower.
It already has 1 duplicates 


Build: NetBeans IDE 6.9.1 Dev (Build 201007262301)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows XP

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.debugger.jpda.models.ArgumentObjectVariable.<init>(ArgumentObjectVariable.java:69)
   at org.netbeans.modules.debugger.jpda.models.CallStackFrameImpl.getMethodArguments(CallStackFrameImpl.java:456)
   at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getLocalVariables(LocalsTreeModel.java:593)
   at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getLocalVariables(LocalsTreeModel.java:548)
   at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getChildrenImpl(LocalsTreeModel.java:142)
   at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getChildren(LocalsTreeModel.java:129)
Comment 1 Alexandr Scherbatiy 2010-07-28 14:40:29 UTC
Created attachment 101067 [details]
stacktrace
Comment 2 Alexandr Scherbatiy 2010-07-28 14:44:24 UTC
Steps to reproduce:

- Copy the code to the editor:
--------------------------------------------
function f() {

    var a = 10;
    var b = 20;
    var c = a + b;
    var d = a - b;

}

f();
--------------------------------------------

- Set a breakpoint to the last line
- Debug the project
- Press F7
- Press Shift+F8 6 more times
  The Java file should open in the editor 

- Stop the debugger
The exception pops up
Comment 3 Martin Entlicher 2010-07-28 14:51:51 UTC
argumentNames[i].getType() must be null. This needs to be handled in Java debugger IMHO.
Comment 4 Martin Entlicher 2010-07-28 16:07:31 UTC
I did not reproduce it on Linux. :-( I'll try to find out where the null type comes from...
Comment 5 Martin Entlicher 2010-07-29 13:16:49 UTC
Unfortunatey I did not find a place where null could be set as an argument type. Does it happen when you're already debugging Java code and not JavaFX?

I've added at least an assert for null type in changeset:   174977:1f95820cf2e0
http://hg.netbeans.org/main/rev/1f95820cf2e0
That will hopefully help us to find out the root cause.
Comment 6 Alexandr Scherbatiy 2010-07-29 13:22:03 UTC
It happens after opening the Method.java file in the editor.
I always press <Shift+F8>.
Comment 7 Quality Engineering 2010-07-30 03:06:59 UTC
Integrated into 'main-golden', will be available in build *201007300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1f95820cf2e0
User: mentlicher@netbeans.org
Log: #189021 Detect null name and type.
Comment 8 Martin Entlicher 2010-08-02 15:01:00 UTC
This seems to be a problem of Java debugger, not JavaFX.
We have also issue #189067 for the same problem.
Comment 9 Martin Entlicher 2010-08-02 15:03:10 UTC
*** Bug 189067 has been marked as a duplicate of this bug. ***
Comment 10 Martin Entlicher 2010-08-02 15:44:02 UTC
I've found that there is already issue #186349 resolved only in 6.10.

*** This bug has been marked as a duplicate of bug 186349 ***
Comment 11 Alexandr Scherbatiy 2010-08-05 09:56:09 UTC
verified in NetBeans IDE Dev (Build 201008050001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo