Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188711 - ClassCastException: com.sun.tools.jdi.ObjectReferenceImpl cannot be cast to com.sun.javafx.jdi.FXObjectReference
ClassCastException: com.sun.tools.jdi.ObjectReferenceImpl cannot be cast to c...
Status: RESOLVED FIXED
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
All All
: P3 (vote)
: TBD
Assigned To: Michal Skvor
issues@javafx
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 18:45 UTC by Torbjorn Norbye
Modified: 2010-08-03 14:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (905 bytes, text/plain)
2010-07-15 18:45 UTC, Torbjorn Norbye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjorn Norbye 2010-07-15 18:45:12 UTC
Build: NetBeans IDE Dev (Build 100713-47bc1387396d)
VM: Java HotSpot(TM) Client VM, 16.3-b01-279, Java(TM) SE Runtime Environment, 1.6.0_20-b02-279-10M3065
OS: Mac OS X

Stacktrace: 
java.lang.ClassCastException: com.sun.tools.jdi.ObjectReferenceImpl cannot be cast to com.sun.javafx.jdi.FXObjectReference
   at org.netbeans.modules.javafx.debugger.variablesfiltering.JavaFXVariablesFilter.getChildren(JavaFXVariablesFilter.java:135)
   at org.netbeans.spi.viewmodel.Models$CompoundTreeModel.getChildren(Models.java:774)
   at org.netbeans.spi.viewmodel.Models$CompoundModel.getChildren(Models.java:3798)
   at org.netbeans.modules.debugger.ui.views.ViewModelListener$1.getChildren(ViewModelListener.java:298)
   at org.netbeans.modules.viewmodel.TreeModelHyperNode$HyperModelChildren.getModelChildren(TreeModelHyperNode.java:238)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.run(TreeModelNode.java:1245)
Comment 1 Torbjorn Norbye 2010-07-15 18:45:16 UTC
Created attachment 100865 [details]
stacktrace
Comment 2 Michal Skvor 2010-08-03 14:02:22 UTC
Can't reproduce. Probably already fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo