Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188659 - IOOBE when stepping through the code
IOOBE when stepping through the code
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Michal Skvor
issues@javafx
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 12:06 UTC by Martin Ryzl
Modified: 2010-08-05 09:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Ryzl 2010-07-14 12:06:06 UTC
following code will cause an exception - see below:

import javafx.scene.*;
import javafx.scene.paint.*;
import javafx.scene.shape.*;

class Main extends CustomNode {
    override function create():Node {
        var a = 100;
        var g =  Group {    // <<< Breakpoint here, then keep pressing F8
            content: for(x in [0..4]) {
                Rectangle {
                    y: indexof x * 20
                    width: bind a
                    height: 10
                    fill:Color.RED
                }
            }
        };
        return g;
    }
}

Main { }




java.lang.IndexOutOfBoundsException: toIndex = 105
	at java.util.SubList.<init>(AbstractList.java:602)
	at java.util.RandomAccessSubList.<init>(AbstractList.java:758)
	at java.util.AbstractList.subList(AbstractList.java:468)
	at org.netbeans.modules.javafx.debugger.models.ScriptClass.getFields(ScriptClass.java:62)
	at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getChildrenImpl(LocalsTreeModel.java:164)
	at org.netbeans.modules.debugger.jpda.models.LocalsTreeModel.getChildren(LocalsTreeModel.java:129)
	at org.netbeans.spi.viewmodel.Models$DelegatingTreeModel.getChildren(Models.java:1510)
	at org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilterSI.getChildren(VariablesTreeModelFilterSI.java:154)
	at org.netbeans.spi.viewmodel.Models$CompoundTreeModel.getChildren(Models.java:774)
	at org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilter.getChildren(VariablesTreeModelFilter.java:221)
	at org.netbeans.spi.viewmodel.Models$CompoundTreeModel.getChildren(Models.java:774)
	at org.netbeans.modules.javafx.debugger.variablesfiltering.JavaFXVariablesFilter.getChildren(JavaFXVariablesFilter.java:184)
	at org.netbeans.spi.viewmodel.Models$CompoundTreeModel.getChildren(Models.java:774)
	at org.netbeans.spi.viewmodel.Models$CompoundModel.getChildren(Models.java:3798)
	at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.getModelChildren(TreeModelNode.java:1285)
	at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.run(TreeModelNode.java:1245)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
Comment 1 Michal Skvor 2010-07-15 17:04:51 UTC
Works for me, I don't get any exceptions at all.
Comment 2 Martin Ryzl 2010-07-15 17:14:06 UTC
still the same - 100% reproducible on my machine even with today's builds
Comment 3 Michal Skvor 2010-08-03 13:40:08 UTC
Already fixed.
Comment 4 Alexandr Scherbatiy 2010-08-05 09:31:26 UTC
verified in NetBeans IDE Dev (Build 201008050001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo