Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188603 - Netbinox does not work with 3.5.2.R35x_v20100126
Netbinox does not work with 3.5.2.R35x_v20100126
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Netigso
6.x
Other Linux
: P1 (vote)
: 7.0
Assigned To: Jaroslav Tulach
issues@platform
69patch1
:
: 189925 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 18:46 UTC by Jaroslav Tulach
Modified: 2010-08-27 07:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2010-07-12 18:46:04 UTC
Looks like the 6.9 support for OSGi does not work well with 3.5.2 version of equinox. The 6.9 "netigso" support is using:

Enumeration en = bundle.findEntries("", "", true);

to get all entries from a bundle. This works OK with Felix, as well as Equinox 3.5, but with new version the en is null. The fix is to

Enumeration en = bundle.findEntries("", null, true);
Comment 1 Jaroslav Tulach 2010-07-12 19:20:04 UTC
core-main#682caf73619e (rooted at release69_base)
Comment 2 Quality Engineering 2010-07-14 02:44:04 UTC
Integrated into 'main-golden', will be available in build *201007140001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/682caf73619e
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #188603: Using null parameter which seems to work with equinox 3.5.2 and checking for null return value
Comment 3 Jaroslav Tulach 2010-07-16 13:20:40 UTC
Netbinox build with equinox 3.5.2 and this fix:
http://hudson.apidesign.org/hudson/job/netbinox/313/
succeeded. Marking verified.
Comment 4 pgebauer 2010-07-16 13:42:37 UTC
The fix has been ported into the release691 branch.
http://hg.netbeans.org/release691/rev/d2699cf6fc62
Comment 5 Jaroslav Tulach 2010-08-27 07:34:09 UTC
*** Bug 189925 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo