Bug 188103 - Profiling Snapshot when NetBeans 6.9 runs extremely slow
Profiling Snapshot when NetBeans 6.9 runs extremely slow
Status: RESOLVED DUPLICATE of bug 188155
Product: php
Classification: Unclassified
Component: Editor
6.x
PC Other
: P3 (vote)
: 7.0
Assigned To: rmatous
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 20:03 UTC by pulsorock
Modified: 2010-07-16 13:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Profiling Snapshot (2.93 MB, application/octet-stream)
2010-06-25 20:03 UTC, pulsorock
Details
profiling snapshot on Ubuntu (754.26 KB, application/octet-stream)
2010-07-13 16:46 UTC, bingalls
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pulsorock 2010-06-25 20:03:34 UTC
Created attachment 100428 [details]
Profiling Snapshot

Here is the Profiling Snapshot of my machine. I've running into lots of problems since 6.9 was released. 

The main one is the IDE running very slow and using over 50% of CPU. 

The other is I can't rename variables (Ctrl+R) as I used to, it gives me the message: "The Rename refactoring cannot be applied in this context."

Also, I can't go to a declaration of a function: 
$this->model_name->functionName($vars)
using Ctrl+Click as I used to do in 6.8

Those are my main issues with 6.9

Thanks
Comment 1 bingalls 2010-07-13 16:46:25 UTC
Created attachment 100809 [details]
profiling snapshot on Ubuntu

This is a snapshot of the "Scanning Files..." that constantly runs on my Ubuntu partition. Note that Windows Netbeans 6.9 with the same PHP project performs fine.

I'm not sure if this is helpful, as I was only able to capture this snapshot, because NetBeans 6.9 was responsive for this time. Usually, NetBeans 6.9 consumes 85% - 100% of both CPUs, making it impossible to click the profile button, or respond to Alt-Shift-Y.
Comment 2 Petr Jiricka 2010-07-14 09:04:37 UTC
Hi, can you please try out the latest NetBeans 6.9.1 release candidate to see if this is still happening?
http://bits.netbeans.org/netbeans/6.9.1/rc/

Thanks.
Comment 3 rmatous 2010-07-16 13:59:44 UTC
Fixed in trunk now:
http://hg.netbeans.org/web-main/rev/2b54057d9d46

This issue might be also fixed into release 6.9.1, but I need verification that
the fix really helps. Thanks to rogojine I was able to reproduce the never
ending loop, so at least in this usecase this fix works.

Problem description: never ending loop for type inference when e.g. method "a"
calls method "b"  and method "b" calls method "a" (on different types but with
the same name). 

Justification for fixing it into relase 6.9.1:
-many duplicates
-complains about it on forums, blogs
(http://blogs.sun.com/netbeansphp/entry/is_the_ide_slow_send#comments)


For verification use please #2079 build (or newer):
http://bertram.netbeans.org/hudson/job/PHP-build/2079/
(http://bertram.netbeans.org/hudson/job/PHP-build/)

PLEASE VERIFY

*** This bug has been marked as a duplicate of bug 188155 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo