Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187932 - Can not create web service from WSDL for Web Logic server
Can not create web service from WSDL for Web Logic server
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: Milan Kuchtiak
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 09:18 UTC by Milan Kuchtiak
Modified: 2010-07-03 03:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kuchtiak 2010-06-22 09:18:43 UTC
The error occurs:
taskdef class com.sun.tools.ws.ant.WsImport cannot be found

This is caused by the fact that jaxws-build.xml wsimport ant task uses the ${j2ee.platform.wsimport.classpath} property, that is not specified for WebLogic.
IDE should test the existence of this property.
Comment 1 Milan Kuchtiak 2010-06-24 08:40:33 UTC
See the changeset:
http://hg.netbeans.org/web-main/rev/b64f572f05bf

Still, there is an issue with endorsed classpath that isn't set in Java EE 5 projects (projects with WebLogic).
Comment 2 Quality Engineering 2010-06-25 03:16:16 UTC
Integrated into 'main-golden', will be available in build *201006250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/b64f572f05bf
User: mkuchtiak@netbeans.org
Log: #187931, #187932: use JAX-WS library for wsimport/wsgen if JAX-WS isn't available on server
Comment 3 Milan Kuchtiak 2010-06-30 13:23:35 UTC
Set wsimport:target attribute to 2.1 (in Java EE 5 projects):
http://hg.netbeans.org/web-main/rev/c3be6b7e2649
Comment 4 Quality Engineering 2010-07-03 03:52:38 UTC
Integrated into 'main-golden', will be available in build *201007030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c3be6b7e2649
User: mkuchtiak@netbeans.org
Log: #187932: set target attribute to 2.1 for wsimport in Java EE5 projects


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo