Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187814 - no horizontal scrollbar in stack view name column
no horizontal scrollbar in stack view name column
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All Solaris
: P2 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@platform
69patch1-verified
:
: 187764 (view as bug list)
Depends on:
Blocks: 187764 188130
  Show dependency treegraph
 
Reported: 2010-06-18 21:53 UTC by Chihin Ko
Modified: 2010-08-19 02:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
statck view image file (13.00 KB, image/png)
2010-06-18 21:53 UTC, Chihin Ko
Details
stack view with horizontal scroll bar (6.60 KB, image/png)
2010-06-24 01:52 UTC, Chihin Ko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chihin Ko 2010-06-18 21:53:25 UTC
Created attachment 100234 [details]
statck view image file

if name is longer than column width, there is no horizontal bar in call stack view.

This happen in netbeans jpda call stack view too.
Comment 1 ivan 2010-06-18 22:28:10 UTC
Note: solstudio IDE doesn't have an All-in-one debugger view so
this is a slightly more important issue for us.
Comment 2 Chihin Ko 2010-06-23 16:01:50 UTC
I think this is a candidate of 6.9.1,
it's a major regression and impact usability
of debugging.
Comment 3 Martin Entlicher 2010-06-23 17:05:56 UTC
Regression? I do not think there were any scroll bars in tables...
Maybe TTV had them? In which NetBeans version did you have scrollbars?
Comment 4 Chihin Ko 2010-06-23 17:44:30 UTC
The sunstudio 12.1 has scrollbar in stack view. which build on top of NB6.5.

The our soltudio builds, the regression happen in between build17 build18.

build17's based NB is dated 2009 March
build18's based NB is dated 2010 Jan
Comment 5 Chihin Ko 2010-06-24 01:52:10 UTC
Created attachment 100370 [details]
stack view with horizontal scroll bar
Comment 6 Chihin Ko 2010-06-24 01:54:26 UTC
see also 187764
Comment 7 Martin Entlicher 2010-06-24 06:37:07 UTC
O.K. I've found that TTV really provides horizontal scroll bar in the tree column. We need to add this to Outline as well...
Comment 8 Alexander Pepin 2010-06-24 10:20:24 UTC
I'm not an expert but IMO it's very risky to make any serious changes now in Outline view.
Comment 9 rbalada 2010-06-25 06:21:08 UTC
Please report on progress with fixing this bug. Deadline is approaching and this bug is not even resolved-fixed. Please inform me if you can do all the work on bugfix and verification by 1 pm Prague time today (for both - time to deliver status and time to deliver verified bugfix).

Thanks,
-R
Comment 10 Martin Entlicher 2010-06-25 06:39:33 UTC
I'm working on the fix, but I'm not sure it can be ready for integration at 1pm.
Comment 11 rbalada 2010-06-25 09:20:48 UTC
Martin,

the list of unresolved 6.9.1_CANDIDATE bugs narrowed down to 1 bug. This bug. And one bug in this state is not making too high risk of unpredictable amount of porting work. In other words - concentrate on your work, I'll try to wait for you :-)

-R
Comment 12 Martin Entlicher 2010-06-25 09:44:50 UTC
The fix will not be ready till 1pm. It's a pity that we do not know the deadline in advance.
Comment 13 Martin Entlicher 2010-06-27 21:11:00 UTC
Fixed in changeset:   173606:684cd80d581e
http://hg.netbeans.org/main/rev/684cd80d581e

Debugger views enable the tree column scrolling by default.
Otherwise the tree column scrolling is not enabled by default in OutlineView.
I've submitted issue #188130 to make the OutlineView.setTreeHorizontalScrollBarPolicy(int) method public.
Comment 14 Martin Entlicher 2010-06-27 21:41:26 UTC
I think that it can be marked as verified, I've tested the fix really extensively. Anyone can test it in dev build http://deadlock.netbeans.org/hudson/job/trunk/8624/artifact/nbbuild/build/*zip*/build.zip or newer.
Comment 15 rbalada 2010-06-27 23:25:52 UTC
main #684cd80d581e transplanted to release691 #7f8c8b83cae8
Comment 16 Quality Engineering 2010-06-29 03:21:42 UTC
Integrated into 'main-golden', will be available in build *201006290001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/684cd80d581e
User: mentlicher@netbeans.org
Log: #187814 Ability to horizontally scroll the tree column added. It's the default for debugger views.
Comment 17 Martin Fousek 2010-07-09 12:14:22 UTC
Checked scrollbars in Call Stack View in NetBeans IDE 6.9.1 Dev (Build 201007062301). Verified.
Comment 18 Chihin Ko 2010-08-19 02:22:51 UTC
*** Bug 187764 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo