Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187783 - ClassCastException: org.openide.nodes.AbstractNode cannot be cast to org.netbeans.modules.viewmodel.TreeModelNode
ClassCastException: org.openide.nodes.AbstractNode cannot be cast to org.netb...
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT, 69patch1-verified
: REGRESSION
: 187878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 12:34 UTC by Alexander Pepin
Modified: 2010-07-16 11:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.14 KB, text/plain)
2010-06-18 12:34 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2010-06-18 12:34:28 UTC
Build: NetBeans IDE 6.9 RC2 (Build 100618-b2a0c70a3202)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows Vista

User Comments:
apepin: Steps to reproduce:
- create any sample e.g. Quote
- do step into
- open Variables view
- do step over
Result: Exception occurs




Stacktrace: 
java.lang.ClassCastException: org.openide.nodes.AbstractNode cannot be cast to org.netbeans.modules.viewmodel.TreeModelNode
   at org.netbeans.modules.viewmodel.DelegatingCellRenderer.getTableCellRendererComponent(DelegatingCellRenderer.java:77)
   at javax.swing.JTable.prepareRenderer(JTable.java:5729)
   at javax.swing.plaf.basic.BasicTableUI.paintCell(BasicTableUI.java:2075)
   at javax.swing.plaf.basic.BasicTableUI.paintCells(BasicTableUI.java:1977)
   at javax.swing.plaf.basic.BasicTableUI.paint(BasicTableUI.java:1773)
   at javax.swing.plaf.ComponentUI.update(ComponentUI.java:143)
Comment 1 Alexander Pepin 2010-06-18 12:34:31 UTC
Created attachment 100204 [details]
stacktrace
Comment 2 Alexander Pepin 2010-06-18 12:46:19 UTC
It's reproduced in 6.9.1 build
Comment 3 Peter Pis 2010-06-21 06:38:52 UTC
Please evaluate.
Comment 4 Martin Entlicher 2010-06-21 06:47:36 UTC
This can not occur in NB 6.9. It's a bug of 6.9.1.
Comment 5 Martin Entlicher 2010-06-21 06:50:03 UTC
And it's already fixed in changeset: 08df974585c9
http://hg.netbeans.org/main/rev/08df974585c9
Comment 6 Peter Pis 2010-06-21 12:20:51 UTC
*** Bug 187878 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Pepin 2010-06-21 12:30:28 UTC
verified in trunk build 20100621
please push the fix into 6.9.1
Comment 8 Martin Entlicher 2010-06-21 12:34:16 UTC
TM is still Next. It's not in 6.9.1 yet. Thanks for your verification.
Comment 9 rbalada 2010-06-21 12:58:05 UTC
transplanted to release691 #1d6604f7c32a
Comment 10 Marian Mirilovic 2010-07-16 11:26:40 UTC
no regressions - verified in NB 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo