Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187725 - I18N : regression : Japanese filename can not be used on Windows
I18N : regression : Japanese filename can not be used on Windows
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@versioncontrol
JA_COMMUNITY 69patch1-verified
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 12:36 UTC by Masaki Katakai
Modified: 2010-07-19 09:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (102.16 KB, image/jpeg)
2010-06-17 12:36 UTC, Masaki Katakai
Details
projects - created by 6.8 and 6.9, including Japanese files in ShiftJIS encoding (26.51 KB, application/x-sdlc)
2010-06-17 12:39 UTC, Masaki Katakai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2010-06-17 12:36:44 UTC
Created attachment 100166 [details]
screenshot

I got a feedback from Japanese user. It seems that mercurial support does not handle Japanese on 6.9 but it works on 6.8. It's a regression from 6.8.

I tried the following steps on both NetBeans 6.8 and 6.9.

1. Start NetBeans on Japanese Windows
   As you know, Japanese Windows is using windows-31j encoding, not UTF-8.

2. Create a project on NetBeans (I'll attach a zip for the projects later)
   Project encoding is UTF-8 by default.

3. Create a Java source file as Japanese name
4. Init repository of mercurial for the project
5. commit
6. Edit some files and commit them

On NetBeans 6.9, japanese characters are garbled on output window and commit window. (See screenshot).

It works on NetBeans 6.8.

The original issue reported from user is:

1. Created a project on 6.8 and made it as mercurial project
2. It contains Japanese filename

There is no project when user commit the sources on NetBeans 6.8. However,

3. Start NetBeans 6.9
4. Open the project and try to commit some files

=> error happens (see screenshot)

So user can not use the old project now.

Is there any quick workaround until it's fixed?
Comment 1 Masaki Katakai 2010-06-17 12:39:07 UTC
Created attachment 100167 [details]
projects - created by 6.8 and 6.9, including Japanese files in ShiftJIS encoding
Comment 2 Ondrej Vrabec 2010-06-22 09:20:22 UTC
mercurial plugin is unusable on windows with national characters in filenames (not just with japanese but e.g. czech chars too). Should be fixed ASAP and integrated into 6.9.1
caused by the fix for bug #155147
Comment 3 Ondrej Vrabec 2010-06-22 09:27:42 UTC
fix: http://hg.netbeans.org/cdev/rev/ab3c08ed488a
Comment 4 Ondrej Vrabec 2010-06-22 09:29:55 UTC
Masaki, please try and verify the fix as soon as the fix makes it to main-golden.
Comment 5 Masaki Katakai 2010-06-23 00:38:22 UTC
Sure! Thank you!
Comment 6 Quality Engineering 2010-06-23 03:28:38 UTC
Integrated into 'main-golden', will be available in build *201006230001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ab3c08ed488a
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #187725 - I18N : regression : Japanese filename can not be used on Windows
reverting fix for #155147, #177575. Using a default encoding and introducing a switch overriding it.
Comment 7 Marian Mirilovic 2010-06-23 11:52:36 UTC
6.9.1 is close to Code Freeze ... so I tried to use it with other languages and haven't encountered any issues - so marked as verified in continuous build from deadlock, to let it be integrated into 6.9.1 on time.

Masaki, it would be still good to see an verification from you, thanks in advance.
Comment 8 Masaki Katakai 2010-06-23 12:36:33 UTC
Sorry for late.

I just tried the build 201006230001 and verified it works ;-)

Great! Thank you very much!
Comment 9 rbalada 2010-06-23 14:38:39 UTC
main #ab3c08ed488a transplanted to release691 #6af1eca5fa13
Comment 10 Jaromir Uhrik 2010-07-19 09:25:50 UTC
Verified in the following 6.9.1 build:

Product Version: NetBeans IDE 6.9.1 Dev (Build 201007182301)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo