Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187585 - IDE hardcodes embeddable EJB container for GlassFish 3.0
IDE hardcodes embeddable EJB container for GlassFish 3.0
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.0
Assigned To: David Konecny
issues@javaee
:
: 191209 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 08:02 UTC by Petr Jiricka
Modified: 2011-02-28 13:40 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-06-15 08:02:04 UTC
When using a hint to add the embeddable EJB container to the project, the IDE will add the version from GF 3.0. See class o.n.m.maven.j2ee.ejb.EjbTestOutputObserver in module maven.j2ee. Instead, the IDE should use the embeddable container for the server that is set as the target server for the project (this will be important when more servers support Java EE 6).

For 6.9.1, we should at least update the container to GF 3.0.1.
Comment 1 Petr Jiricka 2010-06-17 13:43:12 UTC
I tried to update the container to GF 3.0.1, and encountered the following problem: https://glassfish.dev.java.net/issues/show_bug.cgi?id=12278

Also, removing 6.9.1_CANDIDATE, this is probably not worth it.
Comment 2 David Konecny 2010-06-22 01:56:56 UTC
Perhaps HTML editor issue?
Comment 3 David Konecny 2010-06-22 02:07:30 UTC
(In reply to comment #2)
> Perhaps HTML editor issue?

Disregard - it is different issue.
Comment 4 David Konecny 2010-10-07 23:01:44 UTC
See issue 190670 - system scope must be used instead of provided.
Comment 5 David Konecny 2010-11-08 02:05:43 UTC
*** Bug 191209 has been marked as a duplicate of this bug. ***
Comment 6 Petr Jiricka 2010-12-17 11:09:32 UTC
When issue 191590 is addressed, we should remove the current UI (hint on the Maven project), so this bug will become obsolete.
Comment 7 David Konecny 2011-01-20 01:25:06 UTC
While fixing issue 191590 I removed output listener do this issue is obsolete now.
Comment 8 Petr Jiricka 2011-01-21 13:02:36 UTC
Actually, this is still relevant - the new code in EmbeddableEJBContainerHint still hardcodes a GlassFish-specific POM URL. So for JBoss, you are out of luck. The idea of this issue is to acquire the relevant URL from the server plugin, rather than hardcoding it for GlassFish in the server-independent code. 

It is true that we may need a j2eeserver API enhancement for this - for Ant projects, we are using getToolClasspathEntries(TOOL_EMBEDDABLE_EJB) to acquire the classpath, but for Maven this is not usable.

But feel free to treat this as an enhancement rather than a defect.
Comment 9 David Konecny 2011-01-23 20:02:35 UTC
EmbeddableEJBContainerHint handles at the moment only GlassFish servers - version 3 and 3.1. Mainly because GF has very specific way how it deals with Embeddable EJB server. Once there is a JBoss with embeddable EJB server we will have to implement support for it based on how JBoss works.

EmbeddableEJBContainerHint uses ServerPlugins API (ie. getToolClasspathEntries(TOOL_EMBEDDABLE_EJB)) to retrieve location of JAR to add to pom.xml. But despite adding this JAR to pom.xml it needs an artifact name and version to add to pom.xml even if they are never used in practice. And these are hardcoded.

Overall I think this issue is resolved and new issue should be filled for JBoss once it is available.
Comment 10 Petr Jiricka 2011-02-28 13:40:20 UTC
Unit testing on JBoss is filed as a separate issue 191554.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo