Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187567 - [code model] Support for incremental+partial parsing
[code model] Support for incremental+partial parsing
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
7.0
PC Linux
: P1 with 1 vote (vote)
: 7.2
Assigned To: Vladimir Voskresensky
issues@cnd
:
: 197115 208035 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-14 20:20 UTC by rmartins
Modified: 2012-03-30 07:32 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rmartins 2010-06-14 20:20:57 UTC
Hi,
this request would address the problem of lag while editing a source file with a large set of dependencies.

Thanks,
Rolando
Comment 1 Quality Engineering 2010-09-04 03:44:02 UTC
Integrated into 'main-golden', will be available in build *201009040000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8e6f1a9f2561
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: preparation for IZ#187567: [code model] Support for incremental+partial parsing
Comment 2 Quality Engineering 2010-12-16 06:42:57 UTC
Integrated into 'main-golden', will be available in build *201012160001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/fee9557f0336
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 -  [code model] Support for incremental+partial parsing
-- be sensitive to changes in preprocessor directives
Comment 3 Leonid Lenyashin 2011-01-22 20:25:03 UTC
What is the status of this?
Comment 4 Vladimir Voskresensky 2011-01-23 20:39:25 UTC
I'm going to find time and finish it in 7.0.
Looks like small part remains.
Comment 5 Quality Engineering 2011-01-27 08:54:08 UTC
Integrated into 'main-golden', will be available in build *201101270001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2403ae10220c
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567: [code model] Support for incremental+partial parsing
Comment 6 Quality Engineering 2011-01-27 20:48:43 UTC
Integrated into 'main-golden', will be available in build *201101271430* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2403ae10220c
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567: [code model] Support for incremental+partial parsing
Comment 7 Vladimir Voskresensky 2012-02-09 19:26:46 UTC
*** Bug 208035 has been marked as a duplicate of this bug. ***
Comment 8 Quality Engineering 2012-02-21 10:56:16 UTC
Integrated into 'main-golden', will be available in build *201202210400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/87b59420c9c1
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567: [code model] Support for incremental+partial parsing
-- introduce FileImplContent to fill during parse activity (instead of direct changes in FileImpl collections)
Comment 9 Quality Engineering 2012-02-22 11:03:32 UTC
Integrated into 'main-golden', will be available in build *201202220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/87b59420c9c1
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567: [code model] Support for incremental+partial parsing
-- introduce FileImplContent to fill during parse activity (instead of direct changes in FileImpl collections)
Comment 10 Quality Engineering 2012-02-24 09:31:04 UTC
Integrated into 'main-golden', will be available in build *201202240400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/072f4a680244
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 [code model] Support for incremental+partial parsing
- put preprocessor objects into file content instead of putting directly into fileImpl and then update model of file
Comment 11 Quality Engineering 2012-02-28 10:51:06 UTC
Integrated into 'main-golden', will be available in build *201202280400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0bca7dd2b579
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 - [code model] Support for incremental+partial parsing
- FileImplContent -> FileContent
- eleminate side effects in constructor, use external call for put()
- copy constructors for file components
Comment 12 Quality Engineering 2012-03-02 11:17:49 UTC
Integrated into 'main-golden', will be available in build *201203020400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8fe2672545ae
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 [code model] Support for incremental+partial parsing
-- dedicated methods for different type of events
Comment 13 Quality Engineering 2012-03-03 11:33:54 UTC
Integrated into 'main-golden', will be available in build *201203030400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/02e9e124df03
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 [code model] Support for incremental+partial parsing
-- use file signature for partial reparse
Comment 14 Quality Engineering 2012-03-07 18:12:30 UTC
Integrated into 'main-golden', will be available in build *201203071105* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4c66ff774cc1
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 [code model] Support for incremental+partial parsing
-- use file signature for partial reparse (off for now)
Comment 15 Quality Engineering 2012-03-08 11:05:23 UTC
Integrated into 'main-golden', will be available in build *201203080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4345c53043d4
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixing #187567 [code model] Support for incremental+partial parsing
-- allow file impl to collect file signatures and delegate to DeepReparsingUtils for check if partial reparse was enough or not
Comment 16 Quality Engineering 2012-03-11 11:07:29 UTC
Integrated into 'main-golden', will be available in build *201203110400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a54564466851
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: reapply back (not the reason of failing test on mac)
fixing #187567 [code model] Support for incremental+partial parsing
-- allow file impl to collect file signatures and delegate to DeepReparsingUtils for check if partial reparse was enough or not
Comment 17 Vladimir Voskresensky 2012-03-11 11:42:31 UTC
I've turned it ON by default. Please, try to use daily builds and report if you see cases when i.e. navigation jumps into incorrect places (old position of shifted) delcarations
Comment 18 Vladimir Voskresensky 2012-03-30 07:32:08 UTC
*** Bug 197115 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo