Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187454 - Debug Project & File opens two "specify url" windows
Debug Project & File opens two "specify url" windows
Status: CLOSED FIXED
Product: php
Classification: Unclassified
Component: Project
7.0
PC Windows XP
: P2 (vote)
: 7.0
Assigned To: rmatous
issues@php
69patch1-verified
:
: 188244 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 20:31 UTC by DHM5x
Modified: 2013-01-17 17:51 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DHM5x 2010-06-10 20:31:44 UTC
If "Debug URL - Ask Every Time" is enabled and you press either "debug file" or "debug project" two small windows  to specify url opens one are after another.
The first url seems to be used for debugging and the second is used when i press "stop debug". I dont think this is intended, doesnt it should work like in 6.8?

Product Version = NetBeans IDE Dev (Build 201006100001)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_20
Runtime = Java HotSpot(TM) Client VM 16.3-b01
Comment 1 rmatous 2010-06-11 08:24:23 UTC
will be investigated
Comment 3 rmatous 2010-06-11 11:10:36 UTC
Tomasi, be aware of this bug, fixed in the project code.

Unpleasant, probably we should consider to fix in 6.9.1 (maybe even 6.9), so please review
Comment 4 Tomas Mysik 2010-06-11 11:23:41 UTC
Patch seems to be OK. Filip needs to verify. Thanks.
Comment 5 Filip Zamboj 2010-06-12 01:24:20 UTC
verified in web-main. can be pushed to 6.9.1
Comment 6 Quality Engineering 2010-06-12 06:49:40 UTC
Integrated into 'main-golden', will be available in build *201006120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f17631e9d992
User: Radek Matous <rmatous@netbeans.org>
Log: #187454 - Debug Project & File opens two "specify url" windows
Comment 7 rbalada 2010-06-16 10:09:01 UTC
Transplanted to release691 as fc6262dc2e9a
Comment 8 Jaromir Uhrik 2010-07-08 12:03:45 UTC
Verified in the 6.9.1. Only one dialog appears now in the following build:
Product Version: NetBeans IDE 6.9.1 Dev (Build 201007062301)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)
Comment 9 alexey-bass 2010-08-08 09:21:13 UTC
*** Bug 188244 has been marked as a duplicate of this bug. ***
Comment 10 Jegor 2013-01-16 19:19:01 UTC
this bug is still present when I place a breakpoint. netbeans stops on it but when tries to continue, gives the error "socket exception occurred" and the same result on the browser as told by other users.
Comment 11 Ondrej Brejla 2013-01-16 19:26:25 UTC
Sorry, but "socket exception error" is not related to problem with "File opens two "specify url" windows". Mostly it's caused by a failure of xdebug itself, so it disconnects from NB. So please, don't reopen unrelated fixed issues, thanks.

Open a new one with a description of steps how to exactly reproduce a problem (attach simplest debugged project where the problem can be reproduced, message.log and xdebug.log) so then we can evaluate it. Without these exact steps we can't do anything. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo