Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187266 - Add dbxgui to friends list of cnd.model.services
Add dbxgui to friends list of cnd.model.services
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
6.x
PC Solaris
: P2 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
69patch1-verified
:
Depends on:
Blocks: 186305 186306
  Show dependency treegraph
 
Reported: 2010-06-07 12:58 UTC by Egor Ushakov
Modified: 2010-07-07 14:16 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2010-06-07 12:58:26 UTC
dbxgui have to be a friend of cnd.model.services for Autos and Macro debugging features.
Comment 1 Egor Ushakov 2010-06-07 12:59:27 UTC
we will use impl dependency for 6.9 but have to be fixed in 6.9.1
Comment 2 Egor Ushakov 2010-06-07 15:32:12 UTC
fixed in trunk:
http://hg.netbeans.org/cnd-main/rev/9b819b5c68b1
Comment 3 Egor Ushakov 2010-06-07 15:35:05 UTC
Vladimir, please review
Comment 4 Vladimir Voskresensky 2010-06-07 15:49:10 UTC
fix is correct and safe
Comment 5 Vladimir Voskresensky 2010-06-07 15:49:40 UTC
should be integrated into 6.9.1
Comment 6 Quality Engineering 2010-06-08 06:05:49 UTC
Integrated into 'main-golden', will be available in build *201006080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9b819b5c68b1
User: Egor Ushakov <gorrus@netbeans.org>
Log: fixed #187266 (Add dbxgui to friends list of cnd.model.services)
Comment 7 Egor Ushakov 2010-06-08 11:46:17 UTC
integrated into release691 with:
http://hg.netbeans.org/release691/rev/9f9ec3d1799e

do I need to change spec numbers myself?
Comment 8 Egor Ushakov 2010-06-08 13:36:51 UTC
as soon as there will be 6.9 build that would be great to have it in 6.9
Comment 9 Egor Ushakov 2010-06-08 13:37:20 UTC
requires no testing and critical for Solaris Studio
Comment 10 Egor Ushakov 2010-06-08 13:38:37 UTC
integrated into release69 with:
http://hg.netbeans.org/release69/rev/0fcda5147f0a
Comment 11 Alexander Pepin 2010-06-09 14:02:47 UTC
As it's already fixed in 6.9 then it's not a 6.9.1 candidate any more
Comment 12 rbalada 2010-06-14 08:02:17 UTC
added 69patch1 status whiteboard keyword.

Please mark it verified asap.

Sustaining can change spec version for this module, but is there any difference between 6.9 and 6.9.1. As long as there's no difference between 6.9 and 6.9.1 the change in spec version is not necessary.
Comment 13 rbalada 2010-06-14 08:39:02 UTC
Added keyword 6.9.1_CANDIDATE to bugfixes, which were integrated in release69 repository *after* the release691 clone has been created.
Comment 14 Egor Ushakov 2010-06-15 10:01:01 UTC
fix is in 6.9 and 6.9.1 so probably spec version change is not needed
Comment 15 rbalada 2010-06-16 09:11:42 UTC
Egor,

anything new about verification this bug has been fixed?
Comment 16 Egor Ushakov 2010-06-16 09:33:18 UTC
fixed long time ago and integrated to 6.9 and 6.9.1, there is nothing to test here, so do you want me to set it verified?
Comment 17 Vladimir Voskresensky 2010-06-16 09:37:50 UTC
verfied in 6.9 and 6.9.1
Comment 18 rbalada 2010-06-17 13:01:16 UTC
Please to not remove the keyword 6.9.1_CANDIDATE, unless you want me to roll back the change in release691 clone (and cause regression against 6.9 release). The same for 69patch1 status whiteboard keyword.

The reason is that the fix has been integrated into release691 clone *after* it was branched from the release69 clone, so it has to be re-verified in 6.9.1 release.

Thanks,
-R
Comment 19 Egor Ushakov 2010-06-30 19:43:48 UTC
Required to be fixed in SS:
There is no user visible consequence for dbxgui. In fact nothing will fail with 6.9. The only problem is that implementation dependency that we have now *may* stop working after NB update to 6.9.1 or other patches. This fix changes implementation to regular dependency which is less risky.
dbxgui builds with 6.9.1, 6.9 and dev NB finished successfully. Also Vladimir reviewed the fix.
Comment 20 Alexander Pepin 2010-07-07 14:16:16 UTC
verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo