Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187197 - Error message does not print the preferred source root.
Error message does not print the preferred source root.
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
69patch1-verified
: REGRESSION, SIMPLEFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 10:56 UTC by Martin Entlicher
Modified: 2010-07-16 11:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2010-06-04 10:56:28 UTC
When debugger has a different preferred source root from the source root which contains the breakpoint (see e.g. issue #187106), an error message is printed into Debugger Console. The message is like:
"Not able to submit breakpoint LineBreakpoint LogManager.java : 790, reason: Breakpoints source file does not belong into the preferred source root '{0}'. See Window/Debugging/Sources."
where the '{0}' is not replaced with the source root.

Regression caused by the fix of issue #176589.
Comment 1 Martin Entlicher 2010-06-04 11:01:03 UTC
The problem is that MessageFormat.format() does not expand {0} when in single quotes and "breakpoint's" in the message add this single quote.
Comment 2 Martin Entlicher 2010-06-04 12:16:34 UTC
Fixed in changeset:   172497:11b39621b0ea
http://hg.netbeans.org/main/rev/11b39621b0ea
Comment 3 Quality Engineering 2010-06-05 07:47:51 UTC
Integrated into 'main-golden', will be available in build *201006050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/11b39621b0ea
User: mentlicher@netbeans.org
Log: #187197 - Single quotes must be doubled so that they are displayed correctly.
Comment 4 rbalada 2010-06-16 08:56:11 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 5 Petr Blaha 2010-06-17 11:51:49 UTC
verified
Comment 6 rbalada 2010-06-21 14:02:05 UTC
main #11b39621b0ea transplanted to release691 #784902837973
Comment 7 Marian Mirilovic 2010-07-16 11:29:01 UTC
verified in NetBeans IDE 6.9.1 Dev (Build 201007152301)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo