Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187087 - NullPointerException: The name parameter cannot be null
NullPointerException: The name parameter cannot be null
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT, 69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 12:20 UTC by Filip Zamboj
Modified: 2010-07-08 15:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.17 KB, text/plain)
2010-06-02 12:20 UTC, Filip Zamboj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2010-06-02 12:20:33 UTC
Build: NetBeans IDE Dev (Build 2010-06-01_09-04-11 )
VM: Java HotSpot(TM) 64-Bit Server VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Linux

User Comments:
fzamboj: phtml file opened




Stacktrace: 
java.lang.NullPointerException: The name parameter cannot be null
   at org.openide.util.Parameters.notNull(Parameters.java:89)
   at org.openide.util.Parameters.notEmpty(Parameters.java:104)
   at org.netbeans.modules.php.api.editor.PhpBaseElement.<init>(PhpBaseElement.java:60)
   at org.netbeans.modules.php.api.editor.PhpBaseElement.<init>(PhpBaseElement.java:53)
   at org.netbeans.modules.php.api.editor.PhpBaseElement.<init>(PhpBaseElement.java:46)
   at org.netbeans.modules.php.api.editor.PhpBaseElement.<init>(PhpBaseElement.java:27)
Comment 1 Filip Zamboj 2010-06-02 12:20:36 UTC
Created attachment 99755 [details]
stacktrace
Comment 2 Tomas Mysik 2010-06-02 12:36:43 UTC
Caused by fixing issue #186858 so it needs to be a candidate for NB 6.9.1 as well.
Comment 3 Tomas Mysik 2010-06-04 08:09:25 UTC
Fixed.
http://hg.netbeans.org/web-main/rev/5c91b3ba49b3
Comment 4 Quality Engineering 2010-06-08 06:07:05 UTC
Integrated into 'main-golden', will be available in build *201006080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5c91b3ba49b3
User: Tomas Mysik <tmysik@netbeans.org>
Log: #187087: NullPointerException: The name parameter cannot be null
Comment 5 rbalada 2010-06-16 08:55:26 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 6 Filip Zamboj 2010-06-16 13:09:38 UTC
verified - can be transplanted into 691

Product Version: NetBeans IDE Dev (Build 100616-79d6c41672ab)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01
Comment 7 rbalada 2010-06-17 14:00:43 UTC
#main 5c91b3ba49b3 transplanted to release691 #699fdacd08f7
Comment 8 Jaromir Uhrik 2010-07-08 15:18:04 UTC
Unable to reproduce. Verified in the latest 6.9.1 build:
Product Version: NetBeans IDE 6.9.1 Dev (Build 201007062301)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo