Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186916 - XML Code Completion: Cursor not placed properly - continued
XML Code Completion: Cursor not placed properly - continued
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Code
6.x
PC All
: P3 (vote)
: 7.0
Assigned To: _ alexpetrov
issues@xml
69patch1-verified
:
: 187807 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 19:03 UTC by oakie3cr
Modified: 2010-07-08 14:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oakie3cr 2010-05-28 19:03:43 UTC
This is a follow up to bug http://netbeans.org/bugzilla/show_bug.cgi?id=186007

NetBeans correctly puts the cursor on the right line, however it is not between the
elements. Compare with html completion.

To reproduce, create any xml element in an xml document, for example <foo>. If
I create the <foo> element and then press ctrl-space I expect it to look like
this:

<foo>|</foo>

where "|" is the location of the cursor. 

When completing in an html document, and when completing in 6.8 it works as
expected. When completing in 6.9-rc1 the cursor is positioned like this (after
the closing element):

<foo></foo>|

I have seen this on both windows and linux.
Comment 1 _ alexpetrov 2010-05-28 20:27:14 UTC
Fixed in trunk: http://hg.netbeans.org/main/rev/8308d6473440
Comment 2 Quality Engineering 2010-05-30 07:09:40 UTC
Integrated into 'main-golden', will be available in build *201005300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8308d6473440
User: Alex Petrov <alexpetrov@netbeans.org>
Log: Fix for issue [#186916]. XML Code Completion: Cursor not placed properly (continued).
Comment 3 oakie3cr 2010-06-03 17:49:10 UTC
I tried that build and it worked just as I expected it to. Thanks.

The fix didn't make it into RC2, but I assume that is because of the fix being at almost the same time as the RC release. Is that true? Should we expect it in the the next RC (if there is one) or the full release?
Comment 4 Sergey Lunegov 2010-06-04 07:34:13 UTC
The fix will be available in the next NB release: NB 6.9.1.
Comment 5 rbalada 2010-06-16 08:54:33 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 6 _ alexpetrov 2010-06-16 11:35:06 UTC
Verified on (2010-06-16)
http://nephrite.russia.sun.com:8080/hudson/job/main/lastSuccessfulBuild/artifact/cache/latest/main_244_20100616_1740.zip

Product Version: NetBeans IDE 6.9 RC2 (Build 201005312001)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Linux version 2.6.18-8.el5 running on i386
Comment 7 rbalada 2010-06-16 13:12:07 UTC
Transplanted to release691 as d48b350726ad
Comment 8 _ alexpetrov 2010-06-23 14:59:37 UTC
*** Bug 187807 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Danek 2010-07-08 13:26:54 UTC
cannot reproduce in NetBeans IDE 6.9.1 Dev (Build 201007072301) --> verified in 6.9.1
Comment 10 Michael Nazarov 2010-07-08 14:30:13 UTC
Verified as well.

Product Version: NetBeans IDE 6.9.1 Dev (Build 201007072301)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo