Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186903 - [69cat] Debugger variable not updated
[69cat] Debugger variable not updated
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
69patch1-verified
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 15:48 UTC by ulfzibis
Modified: 2010-07-16 07:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen shot (127.57 KB, image/png)
2010-05-28 15:50 UTC, ulfzibis
Details
Screen shot (139.33 KB, image/png)
2010-06-16 21:10 UTC, ulfzibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2010-05-28 15:48:25 UTC
[ BUILD # : 201005192201 ]
[ JDK VERSION : 1.6.18 ]

Use project from bug 186831, revision 1083,
- use configuration "gen_sherman2_6" to run the debugger
- set conditional breakpoint "i == 145" to line 98
- step into line 105
- in Variables open this.value (length=3)
- step to line 195
--> value length should become 0 (check by mouse hover in source code)
--> this (toString() representation should indicate exception (red)
switch to Output tab and then back to Variables
--> values now appear updated
Comment 1 ulfzibis 2010-05-28 15:50:52 UTC
Created attachment 99622 [details]
Screen shot
Comment 2 ulfzibis 2010-06-16 21:10:02 UTC
Created attachment 100144 [details]
Screen shot

On more test case:
Project:
https://java-nio-charset-enhanced.dev.java.net/source/browse/java-nio-charset-enhanced/branches/JDK-7/j_l_Character_names/?rev=1099
File:
https://java-nio-charset-enhanced.dev.java.net/source/browse/java-nio-charset-enhanced/branches/JDK-7/j_l_Character_names/src_sherman2/build/tools/generatecharacter/CharacterNamesGenerator7.java?rev=1099&view=markup
- set breakpoint to line 76
- enable CoS
- run project (configuration=gen_sherman2_7)
- at bp continue once more
- step to line 77 2 times
- step into
- step over
- open variables as shown in screenshot
- step into
- step over

After executing line 185 variable value[0] was not updated to 16384 in Variables view.
Comment 3 Martin Entlicher 2010-06-22 11:09:40 UTC
I've reproduced the first test case. In the second the lines seems to be shifted, anyway, the first one seems to be sufficient.
Comment 4 Martin Entlicher 2010-06-22 12:30:58 UTC
It's a random issue, the first time I've reproduced it and later it worked fine.
I've created a small test-case:

public abstract class VarsRefresh {

    Object[] vars = new Object[3];

    public static void main(String[] args) {
        VarsRefresh vr = new VarsRefreshInner();
        vr.changeVars();
    }

    public abstract void changeVars();

    public static class VarsRefreshInner extends VarsRefresh {

        @Override
        public void changeVars() {
            int l = vars.length;
            vars = new Object[] {};
            for (int i = 1; i < 20; i++) {
                vars = new Object[i];
                l = vars.length;
            }
        }
    }
}

While stepping through "changeVars()" method, "vars" variable is sometimes updated and sometimes is not.
Comment 5 ulfzibis 2010-06-22 13:12:24 UTC
(In reply to comment #4)
> It's a random issue, the first time I've reproduced it and later it worked
> fine.
Same to me. I forgot to mention this before. Luckily you got it by 1st try.

> In the second the lines seems to be shifted
Maybe there was a small difference between svn state and my working copy, which I oversaw. It should be small, but sorry anyway.
Comment 6 Martin Entlicher 2010-06-23 12:42:38 UTC
It should be fixed in changeset:   173444:1c8ed36f61d8
http://hg.netbeans.org/main/rev/1c8ed36f61d8

Please verify after it propagates to dev build so that we can integrate it into 6.9.1. Thanks.
Comment 7 Quality Engineering 2010-06-24 03:32:54 UTC
Integrated into 'main-golden', will be available in build *201006240001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1c8ed36f61d8
User: mentlicher@netbeans.org
Log: #186903 Synchronize access to objectToNode map and also remove destroyed nodes.
Comment 8 rbalada 2010-06-25 06:16:31 UTC
Last chance for inclusion in release691.

Please verify within 4 hours from now, since I have got limited time to transplant remaining bugfixes into release691 repository. June 25, 1 PM Prague time is my deadline. After that time, please do also the transplant/porting work if you want to include it.

Thank you for understanding,
-R
Comment 9 Martin Entlicher 2010-06-25 06:41:29 UTC
Marking as verified, it solved the problem for me and I was not aware of any regressions.
Comment 10 rbalada 2010-06-25 08:58:55 UTC
main #1c8ed36f61d8 transplanted to release691 #8aa48318c4c5
Comment 11 Marian Mirilovic 2010-07-16 07:39:40 UTC
verified in NetBeans IDE 6.9.1 Dev (Build 201007152301)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo