Bug 18632 - Text selection operation in the Output Window significantly loads CPU
Text selection operation in the Output Window significantly loads CPU
Status: CLOSED WORKSFORME
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
All All
: P2 (vote)
: 6.x
Assigned To: akemr
ivan
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-13 21:08 UTC by Mikhail Romanov
Modified: 2008-12-23 08:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Romanov 2001-12-13 21:08:35 UTC
Bug found in NB3.3 RC1 (Build 200112051230).

Text selection and unselection operations in the Output Window loads
100% of CPU that causes performance problems on loaded and slow machines.
Comment 1 Jan Zajicek 2001-12-17 13:46:04 UTC
I didn't notice such problem. Which version of JDK are you using?
Comment 2 Mikhail Romanov 2001-12-17 18:25:33 UTC
I'm using JDK1.3.1 on both Windows NT and Solaris.

It's easy to reproduce this problem on selection of very long 
messages or just dragging the mouse in the output window
(push left mouse button and select/unselect text for some time
and simulteneously look at the CPU load).
Comment 3 _ ttran 2001-12-20 18:02:26 UTC
Mikhail, how did you come to the conclusion that there is a
performance problem?  The CPU usage goes up when I select the text (by
dragging the mouse) but then it goes down immediately.  Does the CPU
usage on your case stays at 100% level for a longer period of time? 
Are you sure that  no other process is stealing the CPU?
Comment 4 Mikhail Romanov 2001-12-20 18:29:21 UTC
Hi Trung, I've faced this problem on a quite loaded sparc Solaris
machine when I needed to select a huge piece of output. It turned out
that it's almost impossible to do that because IDE requires 100% of
CPU while selecting text in the Output window. I'm sure that it is IDE
problem because absolutely the same thing happens on Linux and Windows
as well. In all other applications that I've seen before, text
selecting operation required insignificant usage of CPU.
Comment 5 Quality Engineering 2003-07-01 15:56:12 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 6 Quality Engineering 2003-07-01 16:27:28 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 7 Quality Engineering 2008-12-23 08:19:56 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo