Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186284 - Upgrade bundled gems for 6.9
Upgrade bundled gems for 6.9
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Platform
6.x
PC Linux
: P1 (vote)
: 7.0
Assigned To: Erno Mononen
issues@ruby
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 08:50 UTC by Erno Mononen
Modified: 2010-07-09 09:09 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2010-05-18 08:50:48 UTC
AR-JDBC + related to 0.9.6, Rails to 2.3.5 (or 3.x if released in time), ruby-debug-ide to 0.4.10.
Comment 1 Erno Mononen 2010-05-18 13:47:30 UTC
AR-JDBC and friends updated in 30f7c3815324.
Comment 2 Quality Engineering 2010-05-20 06:13:39 UTC
Integrated into 'main-golden', will be available in build *201005192201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/30f7c3815324
User: Erno Mononen <emononen@netbeans.org>
Log: #186284  (part 1)- Upgrade bundled gems for 6.9
- upgraded ar-jdbc + friends to 0.9.6
Comment 3 Erno Mononen 2010-05-27 09:19:38 UTC
The gem updates need to be transplanted to release69.
Comment 4 Martin Balin 2010-05-31 07:51:06 UTC
It is too late to update gems in 6.9 for FCS. This will need to wait for 6.9.1 or patch1.
Comment 5 rbalada 2010-06-22 07:49:40 UTC
Please report on progress, especially if you can make it into 6.9.1, if not please consider removing 6.9.1_CANDIDATE keyword.

Thanks,
-R
Comment 6 Erno Mononen 2010-06-22 10:38:37 UTC
Upgraded the Rails gems to 2.3.8 and Rack to 1.1.0 in c2bb32ced337, which is the last upgrade I plan to do for now. pchytil, can you please verify this as well? thanks.
Comment 7 Quality Engineering 2010-06-23 03:28:00 UTC
Integrated into 'main-golden', will be available in build *201006230001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c2bb32ced337
User: Erno Mononen <emononen@netbeans.org>
Log: #186284 - Upgrade bundled gems for 6.9
Comment 8 Petr Chytil 2010-06-23 10:29:15 UTC
verified in:

Product Version: NetBeans IDE Dev (Build 201006230001)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.6.4 running on x86_64; MacRoman; en_US (nb)
Comment 9 rbalada 2010-06-23 14:33:41 UTC
main #30f7c3815324 transplanted to release691 #7b0d8ec7ec45
main #c2bb32ced337 transplanted to release691 #65d19828334a
Comment 10 Martin Fousek 2010-07-09 09:09:58 UTC
I can confirm all mentioned gems except ruby-debug-ide 0.4.10. But I didn't find them in previous two commits which were verified by pchytil, so I suppose that ruby-debug-ide was excluded from gems for update.

In any case both commits are transplanted successfully - gems were verified in NetBeans IDE 6.9.1 Dev (Build 201007062301).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo