Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186096 - Can not jump from stack trace in WebLogic log window to source code
Can not jump from stack trace in WebLogic log window to source code
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: WebLogic
6.x
PC Mac OS X
: P2 (vote)
: 7.0
Assigned To: Denis Anisimov
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 13:06 UTC by Petr Jiricka
Modified: 2010-07-20 03:15 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-05-13 13:06:47 UTC
I got an exception while deploying a web application to WebLogic, and this exception appeared in the server log window ("Oracle WebLogic Server"). However, there are no hyperlinks that would allow me to jump to source code for my project's classes. Here is a snippet of the exception:

Caused by: java.lang.NullPointerException
        at entities.CustomerJpaController.getEntityManager(CustomerJpaController.java:31)
        at entities.CustomerJpaController.getCustomerCount(CustomerJpaController.java:175)
        at entities.CustomerController.getPagingInfo(CustomerController.java:40)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
Comment 1 Petr Jiricka 2010-05-13 13:07:02 UTC
The same scenario works for Tomcat.
Comment 2 Petr Hejl 2010-05-13 13:11:10 UTC
This is not yet implemented for WL.
Comment 3 Denis Anisimov 2010-07-19 14:31:41 UTC
changeset:   174498:a5da3d3bf295
user:        Denis Anisimov <ads@netbeans.org>
date:        Mon Jul 19 14:35:45 2010 +0400
summary:     Fix for BZ#186096  -  Can not jump from stack trace in WebLogic log window to source code
Comment 4 Quality Engineering 2010-07-20 03:15:56 UTC
Integrated into 'main-golden', will be available in build *201007200001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a5da3d3bf295
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#186096  -  Can not jump from stack trace in WebLogic log window to source code


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo