Bug 185906 - [69cat] 14s in org.netbeans.modules.options.CategoryModel$MasterLookup.beforeLookup()
[69cat] 14s in org.netbeans.modules.options.CategoryModel$MasterLookup.before...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
All All
: P2 with 1 vote (vote)
: 7.4
Assigned To: Theofanis Oikonomou
issues@platform
EXCEPTIONS_REPORT perf-profileme
: 7.3_WAIVER_APPROVED, PERFORMANCE, PLAN
: 184228 189060 208346 213592 214323 214997 222619 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 13:07 UTC by Exceptions Reporter
Modified: 2013-03-07 01:57 UTC (History)
21 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (68.98 KB, application/nps)
2010-05-11 13:08 UTC, Exceptions Reporter
Details
nps snapshot (9.73 KB, application/nps)
2010-05-17 19:01 UTC, baffyofdaffy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-05-11 13:07:51 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows XP

User Comments:
GUEST: Tools -> Options -> Editor -> Hints
for the first time

GUEST: Opening hint



Maximum slowness yet reported was 28126 ms, average is 13117
Comment 1 Exceptions Reporter 2010-05-11 13:08:01 UTC
Created attachment 98762 [details]
nps snapshot
Comment 2 baffyofdaffy 2010-05-17 19:01:55 UTC
Created attachment 99104 [details]
nps snapshot

Clicked "Hints" in Editor Settings
Comment 3 Milutin Kristofic 2012-06-05 13:33:29 UTC
*** Bug 213592 has been marked as a duplicate of this bug. ***
Comment 4 Theofanis Oikonomou 2012-10-24 15:54:33 UTC
*** Bug 184228 has been marked as a duplicate of this bug. ***
Comment 5 Theofanis Oikonomou 2012-10-24 15:54:49 UTC
*** Bug 189060 has been marked as a duplicate of this bug. ***
Comment 6 Theofanis Oikonomou 2012-10-24 15:55:07 UTC
*** Bug 208346 has been marked as a duplicate of this bug. ***
Comment 7 Theofanis Oikonomou 2012-10-24 15:59:13 UTC
*** Bug 214997 has been marked as a duplicate of this bug. ***
Comment 8 Theofanis Oikonomou 2012-10-24 16:07:50 UTC
options should not wait in the EDT for loading the available categories or some
provider to return/update its panel. I will work on a fix here. Planning for next release.
Comment 9 Theofanis Oikonomou 2012-10-25 09:59:08 UTC
*** Bug 214323 has been marked as a duplicate of this bug. ***
Comment 10 Theofanis Oikonomou 2012-11-29 15:39:15 UTC
*** Bug 222619 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Simon 2012-12-20 17:28:10 UTC
+100 reports and 7 duplicates => P2
Comment 12 greggwon 2012-12-21 18:30:30 UTC
Throughout Netbeans, I have never seen a consistent strategy for managing EDT and background/non-UI thread activity.  For ages, the greater Swing and AWT development community has done things like SwingWorker, FoxTrot and many other variations, trying to work out a good way to "manage" this issue.

I have a class, SyncThread, in the swingutil project on java.net, which does it the way that I need it done in the clients that I write, which use a security manager, and run out of a downloaded jar, where the Context ClassLoader matters.

What bothers me here, is that I see absolutely no reason why callers into this code, which will already "block" due to the API design, can't be burdened with the use of a SwingWorker like dispatch of EDT activities vs background tasks.

There is no reason to "burden" the API design with EDT vs non-EDT changes without just doing a complete rewrite so that the API design is inverted and call backs go out to the user, on non-EDT threads, to "generate" data.

It is really, no, completely frustrating, that Netbeans can not, finally, set the standard for how this is done, and demonstrate a workable solution, once and for all.

How many 10s, or 100s of issues are going to need to be opened?  How many different modules are going to have to do this, over and over, before something dramatic is done, to finally provide a working, general purpose solution to EDT vs non-EDT thread management?
Comment 13 Theofanis Oikonomou 2013-03-06 09:07:26 UTC
Changeset: 7d048e8fa0b6
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-03-06 10:05
Message:
Comment 14 Quality Engineering 2013-03-07 01:57:32 UTC
Integrated into 'main-golden', will be available in build *201303062300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7d048e8fa0b6
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #185906 - [69cat] 14s in org.netbeans.modules.options.CategoryModel$MasterLookup.beforeLookup()


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo