Bug 185775 - ClassCastException: com.sun.tools.javac.code.Type$ClassType cannot be cast to com.sun.tools.javac.code.Type$MethodType
ClassCastException: com.sun.tools.javac.code.Type$ClassType cannot be cast to...
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 227114 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 15:25 UTC by ostermann_bernd
Modified: 2016-07-07 07:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.57 KB, text/plain)
2010-05-08 15:25 UTC, ostermann_bernd
Details
stacktrace (4.57 KB, text/plain)
2010-05-10 10:46 UTC, ostermann_bernd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ostermann_bernd 2010-05-08 15:25:43 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows XP

User Comments:
ostermann_bernd: Scanning projects

ostermann_bernd: Assigning Java SDK6_20 to projects




Stacktrace: 
java.lang.ClassCastException: com.sun.tools.javac.code.Type$ClassType cannot be cast to com.sun.tools.javac.code.Type$MethodType
   at com.sun.tools.javac.jvm.Items$StaticItem.invoke(Items.java:456)
   at com.sun.tools.javac.jvm.Gen.visitApply(Gen.java:1686)
   at com.sun.tools.javac.tree.JCTree$JCMethodInvocation.accept(JCTree.java:1304)
   at com.sun.tools.javac.jvm.Gen.genExpr(Gen.java:839)
   at com.sun.tools.javac.jvm.Gen.visitExec(Gen.java:1631)
   at com.sun.tools.javac.tree.JCTree$JCExpressionStatement.accept(JCTree.java:1150)
Comment 1 ostermann_bernd 2010-05-08 15:25:48 UTC
Created attachment 98676 [details]
stacktrace
Comment 2 Dusan Balek 2010-05-10 07:28:01 UTC
Are you able to reproduce the issue with clean caches (deleted var/cache subdirectory of your userdir)?
Comment 3 ostermann_bernd 2010-05-10 10:46:19 UTC
Created attachment 98709 [details]
stacktrace

Scanning projects after deleting var/cache of userdir.
s. #Bug 185775
Comment 4 ostermann_bernd 2010-05-10 10:50:10 UTC
(In reply to comment #2)
> Are you able to reproduce the issue with clean caches (deleted var/cache
> subdirectory of your userdir)?

Yes, I could reproduce it. The exception occurred while scanning projects without assigning another JDK.
(s. comment #3)
Comment 5 Exceptions Reporter 2011-09-26 23:29:52 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=80107
Comment 6 Exceptions Reporter 2011-09-26 23:31:37 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=80107
Comment 7 Dusan Balek 2015-03-12 13:25:21 UTC
*** Bug 227114 has been marked as a duplicate of this bug. ***
Comment 8 Martin Balin 2016-07-07 07:16:04 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo