Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185726 - [69cat] Find usages should work for the whole classpath
[69cat] Find usages should work for the whole classpath
Status: RESOLVED DUPLICATE of bug 55291
Product: java
Classification: Unclassified
Component: Editor
6.x
PC Windows XP
: P3 with 2 votes (vote)
: 7.3
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 18:13 UTC by ulfzibis
Modified: 2012-07-16 15:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2010-05-07 18:13:18 UTC
[ BUILD # : 201005050200 ]
[ JDK VERSION : 1.6.* ]

Find usages should work for the whole classpath in free form project, even if
not displayed in the project browsers sources tree.
Comment 1 ulfzibis 2010-05-07 18:31:27 UTC
Try sample OpenJDK project.

Was:  http://netbeans.org/projects/nb-openjdk/index.html

But see here: http://openjdk.java.net/groups/nb-projects/
Comment 2 Jan Lahoda 2011-09-29 15:54:48 UTC
Sorry, but the request is not clear to me. Could you please describe in detail what you expect? If you mean that the refactoring should run also on excluded classes, then I believe that would against the very purpose of the exclusion patterns.
Comment 3 stefan79 2011-10-05 06:39:57 UTC
Have a look at Bug #55291.
There are some examples.
Comment 4 Jan Lahoda 2012-07-16 13:34:07 UTC
Not quite sure if that was the original complaint, but need to take it as such given there is no other comment.

*** This bug has been marked as a duplicate of bug 55291 ***
Comment 5 ulfzibis 2012-07-16 15:37:21 UTC
I would say, the complaint is the same, but the environment is different.

In this bug the JDK itself is the project's subject, so I would say the justification to include the entire JDK sources by FU is even stronger than for a project just using the JDK, like described in bug 55291.

But also here I would prefer a new UI - a check-box to say whether you want to search in non-project files or not, but set the the default to search on ALL sources here.
In my understanding, in the sample OpenJDK projects, the whole sources are to be seen as project files, but only filtered for better usability from the Project window and excluding the big work from ant build target.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo