Bug 185519 - java.util.zip.ZipException: error in opening zip file
java.util.zip.ZipException: error in opening zip file
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Antonin Nebuzelsky
issues@apisupport
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 14:29 UTC by Jaroslav Tulach
Modified: 2010-05-10 09:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (821 bytes, text/plain)
2010-05-05 14:29 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2010-05-05 14:29:42 UTC
Build: NetBeans IDE Dev (Build 100503-343fb0de9337)
VM: OpenJDK Client VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_18-b18
OS: Linux

User Comments:
jtulach: Trying to change branding for NbScribble application




Stacktrace: 
java.util.zip.ZipException: error in opening zip file
   at java.util.zip.ZipFile.open(ZipFile.java:0)
   at java.util.zip.ZipFile.<init>(ZipFile.java:131)
   at java.util.jar.JarFile.<init>(JarFile.java:150)
   at java.util.jar.JarFile.<init>(JarFile.java:114)
   at org.netbeans.modules.apisupport.project.ui.branding.ResourceBundleBrandingPanel.prepareTree(ResourceBundleBrandingPanel.java:230)
   at org.netbeans.modules.apisupport.project.ui.branding.ResourceBundleBrandingPanel.access$200(ResourceBundleBrandingPanel.java:96)
Comment 1 Jaroslav Tulach 2010-05-05 14:29:45 UTC
Created attachment 98494 [details]
stacktrace
Comment 2 Jesse Glick 2010-05-05 14:43:27 UTC
Should at least log the ZIP which cannot be opened. Might also be trying to open a nonexistent file, etc.
Comment 3 Antonin Nebuzelsky 2010-05-06 10:56:10 UTC
Reproduced for a case when a suite's module project has not been built yet (its JAR does not exist) and as it is included in the list gathered from LayerUtils.getPlatformJarsForSuiteComponentProject() the branding panel tries opening it.

Making the code more robust to ignore missing JARs: core-main #7130c7abf68c

However, the suite's module project's JAR being included in LayerUtils.getPlatformJarsForSuiteComponentProject() has also another consequence. After the module's JAR becomes available, querying BrandingSupport for its bundle key values results in NPE (issue #185522) because BrandingSupport does not have it in its list of modules for branding. I will follow up on this part in issue #185522.
Comment 4 Quality Engineering 2010-05-10 09:29:16 UTC
Integrated into 'main-golden', will be available in build *201005100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo