Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 185174 - KWalletProvider$KwalletException: error while trying to access KWallet, during save
KWalletProvider$KwalletException: error while trying to access KWallet, durin...
Status: RESOLVED DUPLICATE of bug 216172
Product: platform
Classification: Unclassified
Component: Keyring
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Libor Fischmeistr
issues@platform
:
: 190779 (view as bug list)
Depends on:
Blocks: 179839
  Show dependency treegraph
 
Reported: 2010-04-28 11:51 UTC by mgoe
Modified: 2012-10-10 12:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mgoe 2010-04-28 11:51:51 UTC
The Report Problem Dialog throws the following exception:

SEVERE [global]
org.netbeans.modules.keyring.kde.KWalletProvider$KwalletException: error while trying to access KWallet, during save
        at org.netbeans.modules.keyring.kde.KWalletProvider.save(KWalletProvider.java:96)
        at org.netbeans.api.keyring.Keyring.save(Keyring.java:104)
        at org.netbeans.modules.bugzilla.api.NBBugzillaUtils.saveNBPassword(NBBugzillaUtils.java:118)
        at org.netbeans.modules.bugzilla.exceptionreporter.NBBugzillaAccessorImpl.saveNBPassword(NBBugzillaAccessorImpl.java:80)
        at org.netbeans.modules.exceptions.ExceptionsSettings.setPasswd(ExceptionsSettings.java:113)
        at org.netbeans.modules.exceptions.ReportPanel.saveUserData(ReportPanel.java:304)
        at org.netbeans.modules.uihandler.Installer$SubmitInteractive.closeDialog(Installer.java:1988)
        at org.netbeans.modules.uihandler.Installer$Submit.doCloseDialog(Installer.java:1565)
        at org.netbeans.modules.uihandler.Installer$Submit$1$3.run(Installer.java:1684)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:133)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
[catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Jindrich Sedek 2010-04-28 12:34:37 UTC
Jesse, is this exception expected to be caught in api classes or what should the module using the API do in this case?
Comment 2 Jesse Glick 2010-04-28 19:40:15 UTC
(In reply to comment #1)
> is this exception expected to be caught in api classes or what should
> the module using the API do in this case?

KeyringProvider methods are not permitted to throw random RuntimeException's. If there is a problem it may be logged at an appropriate level (WARNING with no stack trace, or INFO with a stack trace if necessary) but the method should return normally.
Comment 3 Jesse Glick 2010-05-06 13:43:18 UTC
psychollek, do you plan to fix this for 6.9? If so, there is only a week left to do so.
Comment 4 Jesse Glick 2010-10-14 13:27:37 UTC
*** Bug 190779 has been marked as a duplicate of this bug. ***
Comment 5 Libor Fischmeistr 2012-10-10 12:19:59 UTC
Seems like a duplicate.

*** This bug has been marked as a duplicate of bug 216172 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo