Bug 184935 - createSideBarsMap is slow
createSideBarsMap is slow
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 7.0
Assigned To: David Strupl
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 184512 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 19:37 UTC by brodock
Modified: 2010-09-22 07:31 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (20.36 KB, application/nps)
2010-04-25 19:37 UTC, brodock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brodock 2010-04-25 19:37:46 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.3-b01-101, Java(TM) SE Runtime Environment, 1.6.0_17-b04-248-10M3025
OS: Mac OS X

User Comments:
GUEST: problem whit the proxy connection

GUEST: Scanning projects

GUEST: scaning project



Maximum slowness yet reported was 8781 ms, average is 6104
Comment 1 brodock 2010-04-25 19:37:51 UTC
Created attachment 97981 [details]
nps snapshot
Comment 2 David Strupl 2010-09-21 13:41:07 UTC
After trying to find a solution to this problem I am giving up and closing this as wontfix. The problem is that the snapshots show that right after startup the classloading and initialization of parts of the editor is run in AWT EDT. Running the init in shorter chunks is possible but too much effort to implement for too little gain.

If someone disagrees please send in patches - I will happily review and possibly integrate if they will make sense. Thanks for your understanding.
Comment 3 David Strupl 2010-09-22 07:31:04 UTC
*** Bug 184512 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo